Home > Cisco > Router > Cisco Router 826 Routers Software Configuration Guide

Cisco Router 826 Routers Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 826 Routers Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							  
    4-15
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    service udp-small-servers
    service tcp-small-servers
    !
    hostname 2500ref-4
    !
    no logging console
    !
    ip subnet-zero
    no ip domain-lookup
    ip host PAGENT-SECURITY-V3 45.41.44.82 13.15.0.0
    ip dhcp excluded-address 2.2.2.1
    !
    ip dhcp pool 1
    network 2.2.2.0 255.255.255.0
    dns-server 53.26.25.23 
    netbios-name-server 66.22.66.22 
    domain-name ribu.com
    lease 0 0 5
    !
    cns event-service server
    !
    interface Ethernet0
    ip address 192.150.1.101 255.255.255.0
    interface Ethernet1
    ip address 192.168.254.165 255.255.255.0
    interface Serial0
    no ip address
    shutdown
    no fair-queue
    interface Serial1
    no ip address
    shutdown
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.1.1.1
    ip route 0.0.0.0 0.0.0.0 Ethernet0
    no ip http server
    !
    dialer-list 1 protocol ip permit
    line con 0
    exec-timeout 0 0
    transport input none
    line aux 0
    transport input all
    line vty 0 4
    login
    no scheduler max-task-time
    end
    Configuring IP Control Protocol Subnet Mask Delivery
    The IP control protocol subnet mask delivery feature is supported on the following Cisco routers:
    Cisco 826 and Cisco 836
    Cisco 827, Cisco 827H, Cisco 827-4V, Cisco 831, and Cisco 837 
    Cisco 828 
    Cisco SOHO 77, Cisco SOHO 77H, Cisco SOHO 78, Cisco SOHO 91, Cisco SOHO 96, and 
    Cisco SOHO 97 
    						
    							  
    4-16
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    The IP Control Protocol (IPCP) feature assigns IP address pools to customer premises equipment (CPE) 
    devices. These devices then assign IP addresses to the CPE and to a DHCP pool. 
    The IPCP feature provides the following functions:
    The Cisco IOS CPE device requests and uses the subnet.
    The Authentication, Authorization, and Accounting (AAA) Remote Authentication Dial-In User 
    Service (RADIUS) provides the subnet and inserts the framed route into the proper virtual route 
    forwarding (VRF) table.
    The provider edge or the edge router helps in providing the subnet through IPCP.
    DHCP support is no longer on the client side because the CPE can now receive both the IP address and 
    the subnet mask during the PPP setup negotiation. If the CPE uses the DHCP servers to allocate 
    addresses for its own network, subnets can be assigned through the node route processor (NRP) on the 
    network access server (NAS) and distributed to the remote CPE DHCP servers.
    Follow these steps to configure the Cisco router (CPE) for IPCP:
    Step 1Configure the ATM interface, and enter the ADSL operating mode.
    Step 2Configure the ATM subinterface.
    a.Create an ATM PVC for data traffic, enter virtual circuit configuration mode, and specify the VPI 
    and VCI values.
    b.Set the encapsulation of the PVC as aal5mux ppp to support data traffic.
    Step 3Create a dialer interface.
    a.Enter configuration mode for the dialer interface.
    b.Specify the PPP encapsulation type for the PVC.
    c.Enter the ip unnumbered Ethernet 0 command to assign the Ethernet interface to the dialer 
    interface.
    d.Configure the dialer group number. 
    e.Configure CHAP.
    f.Enter the ppp ipcp mask request command.
    g.Assign a dialer list to this dialer interface.
    Step 4Define an IP DHCP pool name.
    a.Enter the import all command.
    b.Enter the origin ipcp command.
    Step 5Configure the Ethernet interface, and assign an IP address pool. Enter the pool name that you defined in 
    Step 4. 
    Step 6Configure a dialer list and a static route for the dialer interface. 
    						
    							  
    4-17
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    Configuration Examples
    The following example shows IPCP configuration on the Cisco router (CPE):
    router-8274v-1# show run
    Building configuration...
    Current configuration :1247 bytes
    version 12.2
    no service single-slot-reload-enable
    no service pad
    service timestamps debug datetime msec
    service timestamps log uptime
    no service password-encryption
    !
    hostname router-8274v-1
    !
    no logging buffered
    logging rate-limit console 10 except errors
    !
    username 6400-nrp2 password 0 lab
    ip subnet-zero
    ip dhcp smart-relay
    !
    ip dhcp pool IPPOOLTEST
    import all
    origin ipcp
    lease 0 0 1
    !
    no ip dhcp-client network-discovery
    !
    interface Ethernet0
    ip address pool IPPOOLTEST
    no shutdown
    hold-queue 32 in
    !
    interface ATM0
    no ip address
    atm ilmi-keepalive
    bundle-enable
    dsl operating-mode auto
    hold-queue 224 in
    !
    interface ATM0.1 point-to-point
    pvc 1/40 
    no ilmi manage
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    interface Dialer0
    ip unnumbered Ethernet0
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname router-8274v-1
    ppp chap password 7 12150415
    ppp ipcp accept-address
    ppp ipcp dns request
    ppp ipcp wins request
    ppp ipcp mask request
    !
    ip classless 
    						
    							  
    4-18
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    !
    dialer-list 1 protocol ip permit
    !
    line con 0
    exec-timeout 0 0
    stopbits 1
    line vty 0 4
    login
    !
    scheduler max-task-time 5000
    end
    The following example shows IPCP configuration on the remote server:
    6400-nrp2#show run
    Building configuration...
    Current configuration :1654 bytes
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname 6400-nrp2
    !
    aaa new-model
    aaa authentication ppp default group radius
    aaa authorization network default group radius 
    aaa nas port extended
    enable password lab
    !
    username router-8274v-1 password 0 lab
    username TB2-8274v-2 password 0 lab
    !
    redundancy
    main-cpu
    auto-sync standard
    no secondary console enable
    ip subnet-zero
    no ip finger
    !
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    hold-queue 500 in
    !
    interface ATM0/0/0.4 point-to-point
    pvc 6/40 
    encapsulation aal5mux ppp Virtual-Template5
    !
    !interface ATM0/0/0.5 point-to-point
    pvc 5/46 
    protocol ip 7.0.0.60 broadcast
    encapsulation aal5mux ppp Virtual-Template6
    !
    interface Ethernet0/0/1
    no ip address
    shutdown
    !
    interface Ethernet0/0/0
    description admin IP address 192.168.254.201 255.255.255.0
    ip address 192.168.254.240 255.255.255.0 
    						
    							  
    4-19
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    !
    interface FastEthernet0/0/0
    ip address 192.168.100.101 255.255.255.0
    half-duplex
    !
    interface Virtual-Template5
    ip unnumbered FastEthernet0/0/0
    no keepalive
    no peer default ip address
    ppp authentication chap
    !
    interface Virtual-Template6
    ip unnumbered FastEthernet0/0/0
    no peer default ip address
    ppp authentication chap
    !
    ip classless
    no ip http server
    !
    ip radius source-interface FastEthernet0/0/0
    !
    radius-server host 192.168.100.100 auth-port 1645 acct-port 1646
    radius-server retransmit 3
    radius-server attribute nas-port format d
    radius-server key foo
    !
    line con 0
    exec-timeout 0 0
    transport input none
    line aux 0
    line vty 0 4
     password lab
    !
    end
    The following example shows IPCP configuration on the RADIUS server (Cisco Access Registrar 1.5):
    /opt/AICar1/usrbin-4 % ./aregcmd
    Access Registrar Configuration Utility Version 1.5
    Copyright (C) 1995-1998 by American Internet Corporation, and 1998-2000 by
     Cisco Systems, Inc.  All rights reserved.
    Cluster:localhost
    User:admin
    Password:
    Logging in to localhost
    400 Login failed/opt/AICar1/usrbin-5 % ./aregcmd
    Access Registrar Configuration Utility Version 1.5
    Copyright (C) 1995-1998 by American Internet Corporation, and 1998-2000 by
     Cisco Systems, Inc.  All rights reserved.
    Cluster:localhost
    User:admin
    Password:
    Logging in to localhost
    [ //localhost ]
        LicenseKey = SBUC-7DQF-PM1E-5HPC (expires in 51 days)
        Radius/
        Administrators/
    Server Radius is Running, its health is 10 out of 10
    --> cd radius
    [ //localhost/Radius ]
        Name = Radius 
    						
    							  
    4-20
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
        Description = 
        Version = 1.6R1
        IncomingScript~ = 
        OutgoingScript~ = 
        DefaultAuthenticationService~ = local-users
        DefaultAuthorizationService~ = local-users
        DefaultAccountingService~ = local-file
        DefaultSessionService~ = 
        DefaultSessionManager~ = 
        UserLists/
        UserGroups/
        Policies/
        Clients/
        Vendors/
        Scripts/
        Services/
        SessionManagers/
        ResourceManagers/
        Profiles/
        Rules/
        Translations/
        TranslationGroups/
        RemoteServers/
        Advanced/
        Replication/
    --> cd profile
    [ //localhost/Radius/Profiles ]
    ls
        Entries 1 to 6 from 6 total entries
        Current filter:
        default-PPP-users/
        default-SLIP-users/
        default-Telnet-users/
        StaticIP/
        router-8274v-1/
        TB2-8274v-2/
    --> ls
    [ //localhost/Radius/Profiles ]
        Entries 1 to 6 from 6 total entries
        Current filter:
        default-PPP-users/
        default-SLIP-users/
        default-Telnet-users/
        StaticIP/
        router-8274v-1/
        TB2-8274v-2/
    --> cd router-8274v-1
    [ //localhost/Radius/Profiles/router-8274v-1 ]
        Name = router-8274v-1
        Description = 
        Attributes/
    --> ls
    [ //localhost/Radius/Profiles/router-8274v-1 ]
        Name = router-8274v-1 
    						
    							  
    4-21
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring the Service Assurance Agent
        Description = 
        Attributes/
    --> cd attribute
    [ //localhost/Radius/Profiles/router-8274v-1/Attributes ]
        cisco-avpair = ip:wins-servers=100.100.100.100 200.200.200.200
        cisco-avpair = ip:dns-servers=60.60.60.60 70.70.70.70
        Framed-Compression = none
        Framed-IP-Address = 40.1.2.30
        Framed-IP-Netmask = 255.255.255.0
        Framed-MTU = 1500
        Framed-Protoc
    l = ppp
        Framed-Routing = None
        Service-Type = Framed
    Configuring the Service Assurance Agent
    The Service Assurance Agent (SAA) can be configured on the following Cisco routers:
    Cisco 826 and Cisco 836
    Cisco 827, Cisco 827H, Cisco 827-4V, Cisco 831, and Cisco 837
    Cisco 828
    Cisco SOHO 77, Cisco SOHO 77H, Cisco SOHO 78, Cisco SOHO 96, and Cisco SOHO 97
    The Service Assurance Agent (SAA) is an agent that monitors network performance by measuring key 
    factors such as response time, availability, jitter, connect time, throughput, and packet loss. 
    The SA agent is a new name and an enhancement for the Response Time Reporter (RTR) feature 
    introduced in Cisco IOS Release 11.2. 
    For configuration information on this command, see the following URL:
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/
    fun_c/fcprt3/fcd301d.htm#xtocid135130
    Configuring Secure Shell
    Secure Shell (SSH) is supported on the following Cisco routers:
    Cisco 826 and 836
    Cisco 827, 827H, 827-4V, 831, and 837
    Cisco 828
    Cisco SOHO 91, SOHO 96, and SOHO 97
    SSH is a protocol that provides a secure and remote connection to a router. SSH is available in two 
    versions, SSH Version 1 and SSH Version 2. Only SSH Version 1 is available in the Cisco IOS software. 
    For configuration information on this command, see the following URL:
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/
    120limit/120s/120s5/sshv1.htm 
    						
    							  
    4-22
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring IP Named Access Lists
    Configuring IP Named Access Lists
    IP named access lists are supported on the following Cisco routers:
    Cisco 826 and Cisco 836
    Cisco 827, Cisco 827H, Cisco 827-4V, Cisco 831, and Cisco 837
    Cisco 828 
    Cisco SOHO 77, Cisco SOHO 77H, Cisco SOHO 78, Cisco SOHO 96, and Cisco SOHO 97
    You can identify IP access lists with an alphanumeric string (name) instead of a number. When you use 
    named access lists, you can configure more IP access lists in a router. 
    For configuration information on this command, see the following URL:
    http://cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_c/
    ipcprt1/1cdip.htm#xtocid2299616
    Configuring International Phone Support
    Cisco 827-4V routers provide international phone support (H.323 only) for the following countries:
    Italy
    Denmark
    Australia
    International phone support commands configure voice port settings and caller ID settings. 
    H.323 international phone support has been tested and verified to work with the following equipment 
    identified for Italy and Denmark.
    The following devices are supported in Italy:
    Telephones:
    –Siemens Gigaset 3015 Class Model
    –Telecom Italia MASTER s.p. LUPO VIEW
    –Alcatel Dial Face Mod. SIRIO 2000 Basic A
    Caller-ID Devices:
    –BRONDI INDOVINO
    Fax equipment:
    –Canon FAX-B155
    The following devices are supported in Denmark:
    Telephones:
    –Tele Danmark dana classic
    –Tele Danmark Danafon Topas 
    Caller-ID Devices:
    –DORO Danmark DOROX5 
    						
    							  
    4-23
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring International Phone Support
    Use the following procedure to configure a voice port to support caller ID, international cadence, 
    impedance, and ring frequency, starting in global configuration mode:
    Step 1Enter the voice-port number command to enter voice-port configuration mode.
    Step 2Enter the cptone country-code command to specify settings for call-progress tone, ring cadence, line 
    impedance, and ring frequency.
    Step 3Enter one of the following commands to enable caller ID:
    Enter the caller-id enable command to enable caller ID support.
    Enter the caller-id alerting alerting-method command to enable caller ID support and to specify the 
    alerting method.
    Step 4Enter the caller-id block command to request blocking of the display of caller ID information at the far 
    end of the call.
    Step 5Enter end to exit router configuration mode.
    Configuration Example
    The following voice-port configuration example shows two voice ports configured for the progress tone 
    and line characteristics for Denmark. Caller ID is enabled on both ports, and port 1 requests that caller 
    ID information be blocked at the other end when a phone call originates from this port. The second port 
    uses the line-reversal alerting method.
    !
    voice-port 1
     cptone dk
     caller-id enable
     caller-id block
     timeouts call-disconnect 0
    !
    voice-port 2
     cptone dk
     caller-id alerting line-reversal
     timeouts call-disconnect 0
    International Tone, Cadence, Ring Frequency, and Impedance Support
    The default voice-port configuration for all voice ports specifies the U.S. country code, 600-ohm 
    impedance, and 25-Hz ring frequency. Cisco IOS software supports commands for setting ring tone, 
    cadence, frequency, and line impedance.
    cptone Command
    Use the voice-port configuration mode cptone command to specify a regional analog voice 
    interface-related tone. Use the no form of this command to disable the selected tone.
    cptone { dk | it | au }
    no cptone { dk | it | au } 
    						
    							  
    4-24
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring International Phone Support
    The following table shows what each code specifies.
    ring cadence Command
    To specify the ring cadence for a Foreign Exchange Station (FXS) voice port, use the ring cadence 
    command in voice-port configuration mode. Use the no form of this command to restore the default 
    value for this command.
    ring cadence cadence
    no ring cadence 
    The ring cadence command can take the following values. Code Country Parameters
    dkDenmark POTS line type 2 (complex impedance), a-law encoding, 
    OSI disconnect supervision, 25-Hz ringing frequency, 0 
    guard time
    itItaly POTS line type 2 (complex impedance), a-law encoding, 
    OSI disconnect supervision, 25-Hz ringing frequency, 0 
    guard time
    auAustralia POTS line type 2 (complex impedance), a-law encoding, 
    OSI disconnect supervision, 20-Hz ringing frequency, 0 
    guard time
    Value Meaning
    define User-defined cadence
    pattern01 2 seconds on, 4 seconds off
    pattern02 1 second on, 4 seconds off
    pattern03 1.5 seconds on, 3.5 seconds off
    pattern04 1 second on, 2 seconds off
    pattern05 1 second on, 5 seconds off
    pattern06 1 second on, 3 seconds off
    pattern07 .8 second on, 3.2 seconds off
    pattern08 1.5 seconds on, 3 seconds off
    pattern09 1.2 seconds on, 3.7 seconds off
    pattern10 1.2 seconds on, 4.7 seconds off
    pattern11 0.4 second on, 0.2 second off, then 
    0.4 second on, 2 seconds off
    pattern12 0.4 second on, 0.2 second off, then 
    0.4 second on, 2.6 seconds off 
    						
    All Cisco manuals Comments (0)