Home > Cisco > Router > Cisco Router 826 Routers Software Configuration Guide

Cisco Router 826 Routers Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 826 Routers Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							  
    3-53
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Cisco 827 Routers Configuration Examples
    Cisco 827-4V Router Configuration 
    The following is a configuration for the Cisco 827-4V router configured for H.323 signaling voice 
    traffic. These commands appear automatically in the configuration file generated when you use the show 
    running-config command.
    ip subnet-zero
    !
    bridge crb
    !
    interface Ethernet0
    no ip address
    no ip directed-broadcast
    bridge-group 1
    !
    interface ATM0
    no ip address
    no ip directed-broadcast
    no atm ilmi-keepalive
    bundle-enable
    !
    interface ATM0.1 point-to-point
    ip address 1.0.0.1 255.255.255.0
    no ip directed-broadcast
    pvc voice 1/40 
    protocol ip 1.0.0.2 broadcast
    encapsulation aal5snap
    !
    !
    interface ATM0.2 point-to-point
    no ip address
    no ip directed-broadcast
    pvc data 1/41 
    encapsulation aal5snap
    !
    bridge-group 1
    !
    ip classless
    !
    bridge 1 protocol ieee
    !
    voice-port 1
    local-alerting
    timeouts call-disconnect 0
    !
    voice-port 2
    local-alerting
    timeouts call-disconnect 0
    !
    voice-port 3
    local-alerting
    timeouts call-disconnect 0
    !
    voice-port 4
    local-alerting
    timeouts call-disconnect 0
    !
    dial-peer voice 101 pots
    destination-pattern 14085271111
    port 1
    !
    dial-peer voice 1100 voip
    destination-pattern 12123451111 
    						
    							  
    3-54
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Cisco 827 Routers Configuration Examples
    codec g711ulaw
    session target ipv4:1.0.0.2
    !
    dial-peer voice 102 pots
    destination-pattern 14085272222
    port 2
    !
    dial-peer voice 1200 voip
    destination-pattern 12123452222
    codec g711ulaw
    session target ipv4:1.0.0.2
    !
    dial-peer voice 103 pots
    destination-pattern 14085273333
    port 3
    !
    dial-peer voice 1300 voip
    destination-pattern 12123453333
    codec g711ulaw
    session target ipv4:1.0.0.2
    !
    dial-peer voice 104 pots
    destination-pattern 14085274444
    port 4
    !
    dial-peer voice 1400 voip
    destination-pattern 12123454444
    codec g711ulaw
    session target ipv4:1.0.0.2
    !
    Cisco 827 Router Configuration 
    The following is a configuration for the Cisco 827 router. These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    Current configuration:
    !
    version 12.2
    no service pad (default)
    service timestamps debug uptime (default)
    service timestamps log uptime (default)
    no service password-encryption (default)
    hostname Cisco827
    enable secret 5 $1$RnI.$K4mh5q4MFetaqKzBbQ7gv0
    ip subnet-zero
    no ip domain-lookup
    ip dhcp-server 20.1.1.2
    ipx routing 0010.7b7e.5499
    !In the preceding command, the router MAC address is automatically used !as the router IPX 
    address.
    !
    interface Ethernet0
    ip address 10.1.1.1 255.255.255.0
    no ip directed-broadcast (default)
    ipx network 100 novell-ether
    !
    interface ATM0
     ip address 14.0.0.17 255.0.0.0
     no ip directed-broadcast (default)
     no atm ilmi-keepalive (default)
    pvc 8/35  
    						
    							  
    3-55
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Cisco 827 Routers Configuration Examples
      protocol ip 14.0.0.1 no broadcast
      encapsulation aal5snap
    !
    router rip
    version 2
    network 10.0.0.0
    network 30.0.0.0
    no auto-summary
    !
    no ip http server (default)
    ip classless (default)
    !
    line con 0
    exec-timeout 10 0
    password 4youreyesonly
    login
    transport input none (default)
    stopbits 1 (default)
    line vty 0 4
    password secret
    login
    !
    end
    Corporate or Endpoint Router Configuration for Data Network
    This section shows a configuration that you can use to configure a Cisco 3600 router as a corporate or 
    endpoint router in your data network.You do not need to enter the commands marked “default.” These 
    commands appear automatically in the configuration file generated when you use the 
    show running-config command.
    Current configuration:
    !
    version 12.2
    no service pad (default)
    service timestamps debug uptime (default)
    service timestamps log uptime (default)
    no service password-encryption (default)
    !
    hostname c3600
    enable secret 5 $1$8TI8$WjLcYWgZ7EZhqH49Y2hJV!
    ip subnet-zero
    no domain-lookup
    ipx routing 0010.7b7e.5498
    !In the preceding command, the router MAC address is automatically used as the router IPX 
    address.
    !
    interface Ethernet0
     ip address 20.0.0.1 255.0.0.0
     no ip directed-broadcast (default)
    ipx network 200
    !
    router rip
    version 2
    network 20.0.0.0
    network 30.0.0.0
    no auto-summary
    !
    no ip http server (default)
    ip classless (default)
    ! 
    						
    							  
    3-56
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Corporate or Endpoint Router Configuration for Data and Voice Network
    protocol ip 2.0.0.1 broadcast
    !
    line con 0
     exec-timeout 0 0
     transport input none (default)
     stopbits 1 (default)
    line vty 0 4
    password secret
    login
    !
    end
    Corporate or Endpoint Router Configuration for Data and Voice 
    Network
    This section shows a configuration that you can use to configure a Cisco 3600 router as a corporate or 
    endpoint router in your data and voice network.You do not need to enter the commands marked 
    “default.” These commands appear automatically in the configuration file generated when you use the 
    show running-config command.
    Current configuration:
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname c3640
    !
    ip subnet-zero
    !
    cns event-service server
    !
    !
    !
    voice-port 1/0/0
     no echo-cancel enable
    !
    voice-port 1/1/0
    !
    voice-port 1/1/1
    !
    dial-peer voice 101 pots
     destination-pattern 5552222
     port 1/0/0
    !
    dial-peer voice 102 pots
     destination-pattern 5554444
     port 1/0/1
    !
    dial-peer voice 103 pots
     destination-pattern 5556666
     port 1/1/0
    !
    dial-peer voice 104 pots
     destination-pattern 5558888
     port 1/1/1
    dial-peer voice 1100 voip 
    						
    							  
    3-57
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Corporate or Endpoint Router Configuration for Data and Voice Network
     destination-pattern 5551111
     codec g711alaw
     ip precedence 5
     no vad
     session target ipv4:2.0.0.3
    !
    dial-peer voice 1101 voip
     destination-pattern 5553333
     codec g711alaw
     ip precedence 5
     no vad
     session target ipv4:2.0.0.3
    !
    dial-peer voice 1102 voip
     destination-pattern 5555555
     codec g711alaw
     ip precedence 5
     session target ipv4:2.0.0.3
    !
    dial-peer voice 1103 voip
     destination-pattern 5557777
     codec g711alaw
     ip precedence 5
     session target ipv4:2.0.0.3
    !
    process-max-time 200
    !
    interface Ethernet0/1
     no ip address
     no ip directed-broadcast (default)
    shutdown
    !
    router rip
    version 2
    network 3.0.0.0
    !
    ip classless (default)
    ip route 0.0.0.0 0.0.0.0 Ethernet 0/0
    ip route 1.0.0.0 255.0.0.0 3.0.0.0
    ip route 2.0.0.0 255.0.0.0 3.0.0.1
    ip route 5.0.0.0 255.0.0.0 3.0.0.1
    ip route 40.0.0.0 255.255.255.0 172.28.9.1
    ip route 172.28.5.0 255.255.255.0 172.28.9.1
    ip route 172.28.9.0 255.255.255.0 172.28.9.1
    no http server
    !
    line con 0
    transport input none (default)
    line aux 0
    line vty 0 4
    login
    !
    end 
    						
    							  
    3-58
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Corporate or Endpoint Router Configuration for Data and Voice Network 
    						
    							CHAPTER
      
    4-1
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    4
    Advanced Router Configuration
    This chapter includes advanced configuration procedures.
    NoteEvery feature described is not necessarily supported on every router model. Where possible and 
    applicable, these feature limitations will be listed.
    If you prefer to use network scenarios to build a network, see Chapter 2, “Network Scenarios.” For basic 
    router configuration topics, see Chapter 3, “Basic Router Configuration.”
    This chapter contains the following sections:
    Configuring PPP over Ethernet Support, page 4-2
    Configuring TCP Maximum Segment Size for PPPoE, page 4-4
    Configuring Low-Latency Queuing and Link Fragmentation and Interleaving, page 4-5
    Configuring Class-Based Traffic Shaping to Support Low Latency Queuing, page 4-7
    Configuring the Length of the PVC Transmit Ring, page 4-10
    Configuring DHCP Server Import, page 4-11
    Configuring IP Control Protocol Subnet Mask Delivery, page 4-15
    Configuring the Service Assurance Agent, page 4-21
    Configuring Secure Shell, page 4-21
    Configuring IP Named Access Lists, page 4-22
    Configuring International Phone Support, page 4-22
    Configuring Committed Access Rate, page 4-27
    Configuring VPN IPSec Support Through NAT, page 4-27
    Configuring VoAAL2 ATM Forum Profile 9 Support, page 4-29
    Configuring ATM OAM F5 Continuity Check Support, page 4-31
    Configuring RADIUS Support, page 4-36
    Configuring Cisco Easy VPN Client, page 4-36
    Configuring Dial-on-Demand Routing for PPPoE Client, page 4-38
    Configuring Weighted Fair Queuing, page 4-40 
    						
    							  
    4-2
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring PPP over Ethernet Support
    Configuring DSL Commands, page 4-41
    Configuring FTP Client, page 4-45
    Each section includes a configuration example and verification steps, where available. 
    Configuring PPP over Ethernet Support
    The following sections describe how to configure PPP over Ethernet support:
    Configuring PPPoE Client Support
    Configuring TCP Maximum Segment Size for PPP over Ethernet
    Configuring PPPoE Client Support
    PPPoE is supported on the following Cisco routers:
    Cisco 826 and Cisco 836
    Cisco 827, Cisco 827H, Cisco 827-4V, and Cisco 837
    Cisco 828 
    Cisco 831
    Cisco SOHO 77, Cisco SOHO 77H, Cisco SOHO 78, Cisco SOHO 96, and Cisco SOHO 97
    This feature supports the PPP over Ethernet (PPPoE) client on an ATM permanent virtual circuit (PVC). 
    Only one PPPoE client on a single ATM PVC is supported.
    A PPPoE session is initiated on the client side by the network described above. If the session has a 
    timeout or is disconnected, the PPPoE client immediately attempts to reestablish the session. 
    Follow these steps to configure the router for PPPoE client support:
    Step 1Configure the virtual private dialup network (VPDN) group number.
    a.Enter the vpdn enable command in global configuration mode.
    b.Configure the VPDN group by entering the vpdn group tag command.
    c.Specify the dialing direction by entering the request-dialin command in the VPDN group.
    d.Specify the type of protocol in the VPDN group by entering the protocol pppoe command. 
    Step 2Configure the ATM interface with PPPoE support.
    a.Configure the ATM interface by entering the interface atm 0 command.
    b.Specify the ATM PVC by entering the pvc number command.
    c.Configure the PPPoE client and specify the dialer interface to use for cloning by entering the 
    pppoe-client dial-pool-number number command. 
    Step 3Configure the dialer interface by entering the int dialer number command.
    a.Configure the IP address as negotiated by entering the ip address negotiated command.
    b.Configure authentication for your network by entering the ppp authentication protocol command. 
    This step is optional.
    c.Configure the dialer pool number by entering the dialer pool number command.  
    						
    							  
    4-3
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring PPP over Ethernet Support
    d.Configure the dialer-group number by entering the dialer-group number command.
    e.Configure a dialer list corresponding to the dialer-group by entering the dialer-list 1 protocol ip 
    permit command.
    NoteMultiple PPPoE clients can run on a different PVCs, in which case, each client has to use a separate 
    dialer interface and a separate dialer pool, and the PPP parameters need to be applied on the dialer 
    interface.
    If you enter the clear vpdn tunnel pppoe command with a PPPoE client session already established, the 
    PPPoE client session terminates and the PPPoE client immediately tries to reestablish the session. 
    Configuration Example
    The following example shows a configuration of a PPPoE client.
    vpdn enable
    vpdn-group 1
    request-dialin
    protocol pppoe
    int atm0
    pvc 1/100
    pppoe-client dial-pool-number 1
    int dialer 1
    ip address negotiated
    ppp authentication chap
    dialer pool 1
    dialer-group 1
    Configuring TCP Maximum Segment Size for PPP over Ethernet
    If a Cisco router terminates the PPP over Ethernet (PPPoE) traffic, a computer connected to the Ethernet 
    interface may have problems accessing websites. The solution is to manually reduce the maximum 
    transmission unit (MTU) configured on the computer by constraining the TCP maximum segment size 
    (MSS). Enter the following command on the router’s Ethernet 0 interface:
    ip tcp adjust-mss mss
    where mss is 1452 or less.
    Network address translation (NAT) must be configured for the ip tcp adjust-mss command to work. 
    This feature is not supported on Cisco SOHO 76 routers.
    Configuration Example
    The following example shows a configuration of a PPPoE client.
    vpdn enable
    no vpdn logging
    ! 
    						
    							  
    4-4
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 4      Advanced Router Configuration
    Configuring TCP Maximum Segment Size for PPPoE
    vpdn-group 1
     request-dialin
      protocol pppoe
    !
    interface Ethernet0
     ip address 192.168.100.1 255.255.255.0
     ip tcp adjust-mss 1452
     ip nat inside
    !
    interface ATM0
     no ip address
     no atm ilmi-keepalive
     pvc 8/35 
      pppoe-client dial-pool-number 1
    !
    dsl operating-mode auto
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username sohodyn password 7 141B1309000528
    !
    ip nat inside source list 101 interface Dialer1 overload
    ip route 0.0.0.0.0.0.0.0 Dialer1
    access-list 101 permit ip 192.168.100.0.0.0.0.255 any
    Configuring TCP Maximum Segment Size for PPPoE
    The configuring TCP maximum segment size for PPP over Ethernet feature is supported on the following 
    Cisco routers:
    Cisco 826 and Cisco 836
    Cisco 827, Cisco 827H, Cisco 827-4V, and Cisco 837
    Cisco SOHO 77, Cisco SOHO 77H, Cisco SOHO 78, Cisco 96, and Cisco SOHO 97
    Cisco 828
    If a Cisco router terminates the PPPoE traffic, a computer connected to the Ethernet interface may have 
    problems accessing websites. The solution is to manually reduce the maximum transmission unit (MTU) 
    configured on the computer by constraining the TCP maximum segment size (MSS). Enter the following 
    command on the router’s Ethernet 0 interface:
    ip tcp adjust-mss mss
    where mss is 1452 or less.
    Network address translation (NAT) must be configured in order for the ip tcp adjust-mss command to 
    work.  
    						
    All Cisco manuals Comments (0)