Home > Cisco > Router > Cisco Router 826 Routers Software Configuration Guide

Cisco Router 826 Routers Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 826 Routers Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							  
    3-3
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Basic Parameters
    Configuring Global Parameters
    Use the following table to configure the router for global parameters.
    For complete information on the global parameter commands, see the Cisco IOS Release 12.2 
    documentation set. 
    Configuring the Ethernet Interface
    To configure the Ethernet interface, use the following table, beginning in global configuration mode.
    For complete information on the Ethernet commands, see the Cisco IOS Release 12.2 documentation set. 
    For more general information on Ethernet concepts, see Chapter 1, “Concepts.”
    NoteThe SOHO 97 Router Ethernet interface remains in an up state when the connected switchport is down 
    and when no cable is connect to the Ethernet interface. In addition, the switchport that is connected to 
    the SOHO 97 Ethernet port stays up when the SOHO 97 Ethernet port is down.
    Configuration Example
    The following example shows the Ethernet interface configuration. You do not need to enter the 
    commands marked “default.” These commands appear automatically in the configuration file generated 
    when you use the show running-config command. Command Purpose
    Step 1configure terminalEnters configuration mode.
    Step 2hostname nameSpecifies the name for the router.
    Step 3enable secret passwordSpecifies an encrypted password to prevent 
    unauthorized access to the router.
    Step 4ip subnet-zeroConfigures the router to recognize zero subnet 
    range as valid range of addresses.
    Step 5no ip domain-lookupDisables the router from translating unfamiliar 
    words (typos) entered during a console session 
    into IP addresses.
    Command Purpose
    Step 1interface ethernet 0Enters configuration mode for the Ethernet 
    interface.
    Step 2ip address ip-address maskSets the IP address and subnet mask for the 
    Ethernet interface.
    Step 3no shutdownEnables the Ethernet interface to change the state 
    from administratively down to up.
    Step 4exitExits configuration mode for the Ethernet 
    interface. 
    						
    							  
    3-4
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Basic Parameters
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    no ip directed-broadcast (default)
    !
    Verifying Your Configuration
    To verify that you have properly configured the Ethernet interface, enter the show interface ethernet0 
    command. You should see a verification output like the example shown below. 
    router#show interface eth0
    Ethernet0 is up, line protocol is up
    Hardware is PQUICC Ethernet, address is 0000.Oc13.a4db 
    (bia0010.9181.1281)
    Internet address is 170.1.4.101/24
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, 
    reliability 255/255., txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Configuring the Dialer Interface 
    Use these commands if you are using PPP encapsulation for the ATM PVC. 
    Use the following table to configure the dialer interface, beginning in global configuration mode.
    Command Purpose
    Step 1interface dialer number  Enters configuration mode for the dialer 
    interface.
    Step 2encapsulation pppSpecifies the encapsulation type for the PVC as 
    PPP.
    Step 3ip address ip-address maskSets the IP address and subnet mask for the dialer 
    interface.
    Step 4dialer pool numberSpecifies which dialer pool number you are 
    using.
    Step 5pvc vpi/vciCreates an ATM PVC for each end node with 
    which the router communicates.
    Step 6encapsulation aal5mux ppp dialerSpecifies the encapsulation type as AAL5MUX 
    PPP.
    Step 7dialer pool-member numberSpecifies a dialer pool-member.
    Step 8dialer-group numberSpecifies a dialer group. The dialer group is 
    required to fast-switch outgoing packets.
    Step 9exitExits configuration mode for the ATM interface. 
    						
    							  
    3-5
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Basic Parameters
    Configuration Example
    The following example shows the dialer interface configuration. You do not need to input the commands 
    marked “default.” These commands appear automatically in the configuration file generated when you 
    use the show running-config command.
    !
    interface atm0
    pvc 1/40
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    interface dialer 0
    ip address 200.200.100.1 255.255.255.0
    encapsulation ppp
    dialer pool 1
    !
    Verifying Your Configuration
    To verify that you have properly configured the dialer interface, enter the show interface virtual-access 
    1 command. Both line protocol and dialer 0 should be up and running. You should see a verification 
    output like the example shown below.
    router(config-if)#show interface virtual-access 1
    Virtual-Access1 is up, line protocol is up 
    Hardware is Virtual Access interface
    Interface is unnumbered. Using address of Dialer0 (2.2.2.1)
    MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Virtual-access 1 is up means that the interface is up and running. If you see the output Virtual-access 
    1 is down, it means that the interface is “administratively down,” and the interface is configured with 
    the shutdown command. To bring the interface up, you must enter the no shutdown command.
    Configuring the Loopback Interface
    This section describes configuring the loopback interface. The loopback interface acts as a placeholder 
    for the static IP address and provides default routing information.
    For complete information on the loopback commands, see the Cisco IOS Release 12.2 documentation 
    set. 
    Configuration Tasks
    Use the following table to configure the loopback interface.
    Command Purpose
    Step 1interface Loopback 0Enters configuration mode for the loopback 
    interface.
    Step 2ip address ip-address maskSets the IP address and subnet mask for the 
    loopback interface. 
    						
    							  
    3-6
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Basic Parameters
    Sample Configuration
    The loopback interface in this sample configuration is used to support NAT on the virtual-template 
    interface. This sample configuration shows the loopback interface configured on the Ethernet interface 
    with an IP address of 200.200.100.1/24, which acts as a static IP address. The loopback interface points 
    back to virtual-template1, which has a negotiated IP address. 
    !
    interface Loopback0
    ip address 200.200.100.1 255.255.255.0 (static IP address)
    ip nat outside
    !
    interface Virtual-Template1
    ip unnumbered loopback0
    no ip directed-broadcast
    ip nat outside
    !
    Verifying Your Configuration
    To verify that you have properly configured the loopback interface, enter the show interface loopback 
    0 command. You should see a verification output similar to the following example.
    Router #show interface loopback 0
    Loopback0 is up, line protocol is up 
      Hardware is Loopback
      Internet address is 200.200.100.1/24
      MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation LOOPBACK, loopback not set
      Last input never, output never, output hang never
      Last clearing of show interface counters never
      Queueing strategy: fifo
      Output queue 0/0, 0 drops; input queue 0/75, 0 drops
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         0 packets input, 0 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 packets output, 0 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
    Another way to verify the loopback interface is to send multiple ping packets to it:
    Router#ping 200.200.100.1 
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
    Step 3ip nat outsideSets the interface to be connected to the outside 
    network.
    Step 4exitExits configuration mode for the loopback 
    interface. Command Purpose 
    						
    							  
    3-7
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Basic Parameters
    Configuring the Asynchronous Transfer Mode Interface
    To configure the Asynchronous Transfer Mode (ATM) interface, use the following table, beginning in 
    global configuration mode.
    NoteThe default service class for configuring the ATM interface is unspecified bit rate (ubr). You can change 
    the service class to variable bit rate non-real time (vbr-nrt) or variable bit rate real time (vbr-rt) by using 
    one of these commands: vbr-nrt or vbr-rt. See the Cisco IOS Release 12.2 documentation set. For more 
    information on definitions of service classes, see Chapter 1, “Concepts.” 
    For complete information on the ATM commands, see the Cisco IOS Release 12.2 documentation set. 
    For more general information on ATM concepts, see Chapter 1, “Concepts.”
    AAL5SNAP Encapsulation Configuration Example 
    The following example shows the ATM interface configuration for AAL5SNAP encapsulation. 
    You do not need to enter the commands marked “default.” These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    !
    interface ATM0
    ip address 200.200.100.1 255.255.255.0
    Command Purpose
    Step 1interface ATM 0Enters configuration mode for the ATM interface.
    Step 2dsl equipment-type {co | cpe} Configures the DSL equipment type, if 
    applicable.
    Step 3dsl linerate {number | auto} Specifies the G.SHDSL line rate, if applicable. 
    The range of valid numbers is between 72 and 
    2312.
    Step 4dsl operating-mode gshdsl symmetric annex 
    annexSets the G.SHDSL operating mode, if applicable, 
    and select the G.991.2 annex.
    Step 5ip address ip-address maskSets the IP address and subnet mask for the ATM 
    interface.
    Step 6pvc vpi/vciCreates an ATM PVC for each end node with 
    which the router communicates.
    Step 7protocol ip ip-address broadcastSets the protocol broadcast for the IP address.
    Step 8encapsulation protocolSpecifies the encapsulation type for the PVC. 
    Encapsulations can be specified as AAL5SNAP, 
    AAL5MUX IP, or AAL5MUX PPP.
    1
    1. This step is optional. If you specify the AAL5MUX PPP encapsulation, you will need to add an additional step to specify the 
    dialer pool-member number using the command dialer-pool member number.
    Step 9tx-ring-limit numberConfigures the size of the PVC transmit queue. 
    The default setting is 6.
    Step 10no shutdownEnables the ATM interface.
    Step 11exitExits configuration mode for the ATM interface. 
    						
    							  
    3-8
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Basic Parameters
    no ip directed-broadcast (default)
    no atm ilmi-keepalive (default)
    pvc 8/35
    encapsulation aal5snap
    protocol ip 200.200.100.254 broadcast
    !
    Verifying Your Configuration
    To verify that you have properly configured the ATM interface with AAL5SNAP encapsulation, enter 
    the show interface atm0 command. You should see a verification output like the example shown below. 
    router#sh int atm0
    ATM0 is up, line protocol is up
    Hardware is PQUICC_SAR (with Alcatel ADSL Module)
    Internet address is 1.1.1.1/24
    MTU 1500 bytes, sub MTU 1500, BW 640 Kbit, DLY 80 usec, reliability
    113/255. txload 1/255, rxload 1/255
    Encapsulation aal5snap, loopback not set
    Keepalive not supported
    DTR is pulsed for 5 seconds on reset
    LCP Closed
    AAL5MUX PPP Encapsulation Configuration Example 
    The following example shows an ATM interface configuration for an AAL5MUX PPP encapsulation. 
    You do not need to enter the commands marked “default.” These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    !
    interface ATM0
    no ip directed-broadcast (default)
    no atm ilmi-keepalive (default)
    pvc 8/35 
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    Verifying Your Configuration
    To verify that you have properly configured the ATM interface with AAL5MUX PPP encapsulation, 
    enter the virtual-access 1 command. You should see a verification output like the example shown below.
    router#sh int virtual-access 1
    Virtual-Access1 is up, line protocol is up 
    Hardware is Virtual Access interface
    Interface is unnumbered. Using address of Dialer0 (2.2.2.1)
    MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Virtual-access 1 is up means that the interface is up and running. If you see the output Virtual-access 
    1 is down, it means that the interface is “administratively down,” and the interface is configured with 
    the shutdown command. To bring the interface up, you must enter the no shutdown command.  
    						
    							  
    3-9
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Bridging
    Configuring Command-Line Access to the Router
    To configure parameters to control access to the router, use the following table, beginning in global 
    configuration mode.
    For complete information on the command line commands, see the Cisco IOS Release 12.2 
    documentation set. 
    Configuration Example
    The following configuration shows the command-line access commands.
    You do not need to input the commands marked “default.” These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    !
    line con 0
    exec-timeout 10 0
    password 4youreyesonly
    login
    transport input none (default)
    stopbits 1 (default)
    line vty 0 4
    password secret
    login
    !
    Configuring Bridging
    Bridges are store-and-forward devices that use unique hardware addresses to filter traffic that would 
    otherwise travel from one segment to another. You can configure the routers as pure bridges.Command Purpose
    Step 1line console 0Enters line configuration mode, and specify the 
    console terminal line.
    Step 2password passwordSpecifies a unique password on the line.
    Step 3loginEnables password checking at terminal session 
    login.
    Step 4exec-timeout 10 0Sets the interval that EXEC command interpreter 
    waits until user input is detected. Exec-timeout 10 
    0 is the default.
    Step 5line vty 0 4Specifies a virtual terminal for remote console 
    access.
    Step 6password passwordSpecifies a unique password on the line.
    Step 7loginEnables password checking at virtual terminal 
    session login.
    Step 8endExits line configuration mode, and return to 
    privileged EXEC mode. 
    						
    							  
    3-10
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Bridging
    To configure bridging, use the following table, beginning in global configuration mode.
    For complete information on the bridging commands, see the Cisco IOS Release 12.2 documentation set. 
    For more general concepts on bridging, see Chapter 1, “Concepts.”
    Configuration Example
    The following configuration example uses bridging with AAL5SNAP encapsulation. You do not need to 
    enter the commands marked “default.” These commands appear automatically in the configuration file 
    generated when you use the show running-config command.
    This configuration example shows the Ethernet and ATM interfaces configured. The Ethernet interface 
    has IP addressing turned off for bridging, and IP directed broadcast is disabled, which prevents the 
    translation of directed broadcasts to physical broadcasts. The bridge-group number to which the ATM 
    interface is associated is set to 1. Command Purpose
    Step 1no ip routingDisables IP routing.
    Step 2bridge number protocol protocolSpecifies the bridge protocol to define the type of 
    Spanning-Tree Protocol (STP).
    Step 3interface ethernet 0Enters configuration mode for the Ethernet 
    interface.
    Step 4bridge-group numberSpecifies the bridge-group number to which the 
    Ethernet interface belongs. 
    Step 5no shutdownEnables the Ethernet interface.
    Step 6exitExits configuration mode for the Ethernet 
    interface and the router.
    Step 7interface ATM 0Enters configuration mode for the ATM interface.
    Step 8dsl equipment-type {co | cpe} Configures the DSL equipment type, if 
    applicable.
    Step 9dsl linerate {number | auto} Specifies the G.SHDSL line rate, if applicable. 
    The range of valid numbers is between 72 and 
    2312.
    Step 10dsl operating-mode gshdsl symmetric annex 
    annexSets the G.SHDSL operating mode, if applicable, 
    and select the G.991.2 annex.
    Step 11pvc vpi/vciCreates an ATM PVC for each end node with 
    which the router communicates.
    Step 12encapsulation typeSpecifies the encapsulation type for the PVC. 
    Step 13bridge-group numberSpecifies the bridge-group number to which the 
    ATM interface belongs. 
    Step 14no shutdownEnables the ATM interface.
    Step 15end  Exits the configuration mode for the ATM 
    interface. 
    						
    							  
    3-11
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Bridging
    The ATM interface has a PVC of 8/35, and the encapsulation is set to AAL5SNAP. The IP address is 
    disabled for bridging and the IP directed broadcast is disabled, which prevents the translation of directed 
    broadcasts to physical broadcasts. The bridge protocol is set to 1 to define the STP.
    no ip routing
    !
    interface Ethernet0
    no ip address
    no ip directed-broadcast (default)
    bridge-group 1
    !
    interface ATM0
    no ip address
    no ip directed-broadcast (default)
    pvc 8/35 
    encapsulation aal5snap
    !
    bridge-group 1
    !
    ip classless (default)
    !
    bridge 1 protocol ieee
    !
    end
    Verifying Your Configuration
    To verify that you have properly configured bridging, enter the show spanning-tree command. You 
    should see a verification output like the example shown below.
    router#show spanning-tree 
    Bridge group 1 is executing the IEEE compatible Spanning Tree protocol
    Bridge Identifier has priority 32768, address 1205.9356.0000
    Configured hello time 2, max age 20, forward delay 15
    We are the root of the spanning tree
    Port Number size is 9
    Topology change flag set, detected flag set
    Times: hold 1, topology change 35, notification 2
    hello 2, max age 20, forward delay 15 
    Timers:hello 1, topology change 34, notification 0
    bridge aging time 15
    Port 2 (Ethernet0) of Bridge group 1 is forwarding
    Port path cost 100, Port priority 128
    Designated root has priority 32768, address 1205.9356.0000
    Designated bridge has priority 32768, address 1205.9356.0000
    Designated port is 2, path cost 0
    Timers:message age 0, forward delay 0, hold 0
    BPDU:sent 0, received 0
    Port 3 (ATM0 RFC 1483) of Bridge group 1 is forwarding
    Port path cost 1562, Port priority 128
    Designated root has priority 32768, address 1205.9356.0000
    Designated bridge has priority 32768, address 1205.9356.0000
    Designated port is 3, path cost 0
    Timers:message age 0, forward delay 0, hold 0
    BPDU:sent 0, received 0 
    						
    							  
    3-12
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Static Routing
    Configuring Static Routing
    Static routes are routing information that you manually configure into the router. If the network topology 
    changes, the static route must be updated with a new route. Static routes are private routes, unless they 
    are redistributed by a routing protocol. Configuring static routing on the 800-series routers is optional.
    To configure static routing, use the following table, beginning in global configuration mode.
    For complete information on the static routing commands, see the Cisco IOS Release 12.2 
    documentation set. For more general information on static routing, see Chapter 1, “Concepts.”
    Configuration Example
    In the following configuration example, the static route is sending all IP packets with a destination of 
    1.0.0.0 and a subnet mask of 255.0.0.0 out on the ATM interface to another device with an IP address of 
    14.0.0.1. Specifically, the packets are being sent to the configured PVC.
    You do not need to enter the commands marked “default.” These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    !
    ip classless (default)
    ip route 1.0.0.0 255.0.0.0 atm0 14.0.0.1 
    no ip http server (default)
    !
    Verifying Your Configuration
    To verify that you have properly configured static routing, enter the show ip route command and look 
    for static routes signified by the “S.” 
    You should see a verification output like the example shown below.
    router#show ip route
    Codes:C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
    inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is 0.0.0.0 to network 0.0.0.0
    5*  2.0.0.0/24 is subnetted, 1 subnets
    C 2.2.2.0 is directly connected, Ethernet0/0
    S* 0.0.0.0/0 is directly connected, Ethernet0/0
    Command Purpose
    Step 1ip classlessSets up a best route for packets destined for 
    networks unknown by the router.
    Step 2ip route network-number mask Specifies the static route for the IP packets.
    Step 3endExits router configuration mode. 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 826 Routers Software Configuration Guide