Home > Cisco > Router > Cisco Router 826 Routers Software Configuration Guide

Cisco Router 826 Routers Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 826 Routers Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							  
    3-13
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Dynamic Routing
    Configuring Dynamic Routing
    In dynamic routing, the network protocol adjusts the path automatically based on network traffic or 
    topology. Changes in dynamic routing are shared with other routers in the network.
    The IP routing protocol can use the Routing Information Protocol (RIP) or the Enhanced Interior 
    Gateway Routing Protocol (IGRP) to learn routes dynamically. You can configure either one of these 
    routing protocols.
    Configuring RIP
    To configure RIP routing protocol on the router, use the following table, beginning in global 
    configuration mode.
    For complete information on the dynamic routing commands, see the Cisco IOS Release 12.2 
    documentation set. For more general information on RIP, see Chapter 1, “Concepts.” 
    Configuration Example
    The following configuration shows RIP version 2 enabled in IP network 10.10.10.0.
    You do not need to enter the commands marked “default.” These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    !
    router rip
    version 2 
    network 10.0.0.0
    no auto-summary
    !
    Verifying Your Configuration
    To verify that you have properly configured RIP, enter the show ip route command and look for RIP 
    routes signified by “R.” You should see a verification output like the example shown below. 
    router#show ip route
    Codes:C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
    Command Task
    Step 1router ripEnter router configuration mode and enable RIP 
    on the router.
    Step 2version 2Specify use of RIP version 2.
    Step 3network network-numberSpecify the network number for each directly 
    connected network.
    Step 4no auto-summaryDisable automatic summarization of subnet routes 
    into network-level routes. This allows subprefix 
    routing information to transmit across classful 
    network boundries.
    Step 5endExit router configuration mode. 
    						
    							  
    3-14
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring IP Enhanced IGRP
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
    inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is not set
         2.0.0.0/24 is subnetted, 1 subnets
    C  2.2.2.0 is directly connected, Ethernet0/0
    R    3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
    Configuring IP Enhanced IGRP
    To configure IP Enhanced IGRP, use the following table, beginning in global configuration mode.
    For complete information on the IP Enhanced IGRP commands, see the Cisco IOS Release 12.2 
    documentation set. For more general information on Enhanced IGRP concepts, see Chapter 1, 
    “Concepts.”
    Configuration Example
    The following configuration shows Enhanced IGRP routing protocol enabled in IP networks 10.0.0.0 and 
    172.17.0.0. The Enhanced IGRP autonomous system number is assigned as 100.
    You do not need to enter the commands marked “default.” These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    !
    router eigrp 100
    network 10.0.0.0
    network 172.17.0.0
    !
    Command Purpose
    Step 1router eigrp autonomous-systemEnters router configuration mode and enable 
    Enhanced IGRP on the router. The 
    autonomous-system number identifies the route 
    to other Enhanced IGRP routers and is used to tag 
    the Enhanced IGRP information.
    Step 2network network-numberSpecifies the network number for each directly 
    connected network.
    Step 3endExits router configuration mode. 
    						
    							  
    3-15
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Addressing Parameters
    Verifying Your Configuration
    To verify that you have properly configured IP Enhanced IGRP, enter the show ip route command and 
    look for Enhanced IGRP routes signified by “D.” You should see a verification output like the example 
    shown below.
    router#show ip route
    Codes:C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is not set
    2.0.0.0/24 is subnetted, 1 subnets
    C  2.2.2.0 is directly connected, Ethernet0/0
    D    3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0
    Configuring Addressing Parameters
    This section describes how to configure addressing using Network Address Translation (NAT) and Easy 
    IP Phase 1 and 2.
    Configuring NAT 
    You can configure NAT for either static or dynamic address translations.
    To configure static or dynamic inside source translation using NAT, use the following table, beginning 
    in global configuration mode.
    Command Purpose
    Step 1ip nat pool name start-ip end-ip {netmask 
    netmask | prefix-length prefix-length}Creates pool of global IP addresses for NAT. 
    Step 2access-list access-list-number permit source 
    [source-wildcard]Defines a standard access list permitting 
    addresses that need translation.
    Step 3ip nat inside source list access-list-number pool 
    nameEnables dynamic translation of addresses 
    permitted by access list to one of addresses 
    specified in pool.
    Step 4ip nat inside source static local-ip global-ip 
    number extendableEnables static translation of specified inside local 
    address to globally unique IP address. This 
    command is optional.
    Step 5interface ethernet 0Enters configuration mode for Ethernet interface.
    Step 6ip nat insideEstablishes Ethernet interface as inside interface.
    Step 7exitExits configuration mode for Ethernet interface.
    Step 8interface atm 0Enters configuration mode for ATM interface. 
    						
    							  
    3-16
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Addressing Parameters
    NoteIf you want to use NAT with a Virtual-Template interface, you must configure a loopback interface.
    For complete information on the NAT commands, see the Cisco IOS Release 12.2 documentation set. 
    For more general information on NAT concepts, see Chapter 1, “Concepts.”
    Configuration Example
    The following configuration shows NAT configured for the Ethernet and ATM interfaces.
    The Ethernet 0 interface has an IP address of 192.168.1.1 with a subnet mask of 255.255.255.0. NAT is 
    configured for inside, which means that the interface is connected to the inside network that is subject 
    to NAT translation.
    The ATM 0 interface has an IP address of 200.200.100.1 and a subnet mask of 255.255.255.0. NAT is 
    configured for outside, which means that the interface is connected to an outside network, such as the 
    Internet.
    You do not need to enter the commands marked “default.” These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    no ip directed-broadcast (default)
    ip nat inside
    !
    interface ATM0
    ip address 200.200.100.1 255.255.255.0
    no ip directed-broadcast (default)
    ip nat outside
    no atm ilmi-keepalive (default)
    pvc 8/35 
    encapsulation aal5snap
    !
    ip route 0.0.0.0.0.0.0.0 200.200.100.254
    !
    ip nat pool test 200.200.100.1 200.200.100.1 netmask 255.255.255.0
    ip nat inside source list 101 pool test overload
    ip classless (default)
    !
    Step 9dsl equipment-type {co | cpe} Configures the DSL equipment type, if 
    applicable.
    Step 10dsl linerate {number | auto} Specifies the G.SHDSL line rate, if applicable. 
    The range of valid numbers is between 72 and 
    2312.
    Step 11dsl operating-mode gshdsl symmetric annex 
    annexSets the G.SHDSL operating mode, if applicable, 
    and select the G.991.2 annex.
    Step 12ip nat outsideEstablishes ATM interface as outside interface.
    Step 13exitExits configuration mode for ATM interface. Command Purpose 
    						
    							  
    3-17
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Addressing Parameters
    Verifying Your Configuration
    To verify that you have properly configured NAT, enter the show ip nat statistics command. You should 
    see a verification output like the example shown below.
    router#show ip nat statistics 
    Total active translations:45 (10 static, 35 dynamic; 45 extended)
    Outside interfaces:
      ATM0
    Inside interfaces:
      Ethernet0
    Hits:34897598  Misses:44367
    Expired translations:119305
    Dynamic mappings:
    -- Inside Source
    access-list 1 pool homenet refcount 14
    pool homenet:netmask 255.255.255.0
            start 200.200.100.1 end 200.200.100.1
            type generic, total addresses 1, allocated 1 (100%), misses 
    Configuring Easy IP (Phase 1)
    This section explains how to configure Easy IP (Phase 1). Easy IP Phase 1 includes NAT overload and 
    PPP/Internet Protocol Control Protocol (IPCP). NAT overload means that you can use one registered IP 
    address for the interface and use it to access the Internet from all devices in the network. 
    With PPP/IPCP, Cisco 800-series routers automatically negotiate a globally unique (registered or public) 
    IP address for the interface from the ISP route.
    To configure Easy IP (Phase 1), use the following table, beginning in global configuration mode.
    Command Purpose
    Step 1access-list access-list-number permit source 
    [source-wildcard] Defines a standard access list that permits 
    nonregistered IP addresses of hosts.
    Step 2ip nat inside source list access-list-number 
    interface interface overloadSets up translation of addresses identified by the 
    access list defined in Step 1.
    Step 3interface ethernet 0Enters configuration mode for Ethernet interface.
    Step 4ip nat insideEstablishes the Ethernet interface as inside 
    interface for NAT.
    Step 5no shutdownEnables the Ethernet interface and the 
    configuration changes just made to it.
    Step 6exitExits configuration mode for Ethernet interface.
    Step 7interface dialer Enters configuration mode for the dialer interface. 
    Step 8ip address negotiatedAssigns a negotiated IP address to the dialer 
    interface.
    Step 9ip nat outsideEstablishes the dialer interface as the outside 
    interface for NAT.
    Step 10dialer pool numberSpecifies which dialer pool number you are using.
    Step 11exitExits the dialer interface.
    Step 12interface ATM 0Enters configuration mode for the ATM interface. 
    						
    							  
    3-18
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring Addressing Parameters
    For complete information on the Easy IP commands, see the Cisco IOS Release 12.2 documentation set. 
    For more general information on Easy IP (Phase 1) concepts, see Chapter 1, “Concepts.” 
    Configuring Easy IP (Phase 2)
    This section explains how to configure the Cisco 800 series routers as DHCP servers.
    The Easy IP (Phase 2) feature combines DHCP server and relay. With DHCP, LAN devices on an IP 
    network (DHCP clients) can request IP addresses from the DHCP server. The DHCP server allocates IP 
    addresses from a central pool as needed. A DHCP server can be a workstation, PC, or a Cisco router. 
    With the DHCP relay feature configured on the router, the routers can relay IP address requests from the 
    LAN interface and to the DHCP server as shown in Figure 3-1.
    Figure 3-1 Easy IP (Phase 2) – DHCP Server and Relay Step 13
    dsl equipment-type {co | cpe} Configures the DSL equipment type, if 
    applicable.
    Step 14dsl linerate {number | auto} Specifies the G.SHDSL line rate, if applicable. 
    The range of valid numbers is between 72 and 
    2312.
    Step 15dsl operating-mode gshdsl symmetric annex 
    annexSets the G.SHDSL operating mode, if applicable, 
    and select the G.991.2 annex.
    Step 16pvc vpi/vciCreates an ATM PVC for each end node with 
    which the router communicates.
    Step 17encapsulation aal5mux ppp dialer Specifies the encapsulation type for the PVC to be 
    AAL5MUX PPP and point back to the dialer 
    interface. 
    Step 18dialer pool-member numberSpecifies which dialer pool-member you are 
    using.
    Step 19no shutdownEnables the interface and configuration changes 
    just made to the ATM interface.
    Step 20exitExits configuration mode for the ATM interface. Command Purpose
    1DHCP client4Corporate office
    2Remote office5DHCP server
    3DHCP relay
    Cisco 827 Cisco 3600
    AT M
    74583
    1
    3
    24
    5 
    						
    							  
    3-19
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring DHCP
    Configuring DHCP
    The following sections describe how to configure the router as a DHCP client, server, or relay.
    Configuring DHCP Client Support
    Follow these steps to configure the router for DHCP client support:
    Step 1Configure the BVI interface by entering the ip address dhcp client-id Ethernet 0 command. 
    Specifying the value client-id ethernet0 means that the MAC address of the Ethernet interface is used as 
    the client ID when the DHCP request is sent. Otherwise, the MAC address of the BVI interface is used 
    as the client ID.
    Step 2Configure NAT:
    a.Configure the BVI interface by entering the ip nat outside command.  
    b.Configure the Ethernet interface by entering the ip nat inside command.
    c.Create an access list under NAT by entering the access-list 1 permit ip address command to match 
    all Ethernet IP addresses.
    d.Configure the source list under NAT by entering the 
    ip nat inside source list 1 interface BVI 1 overload command.
    Step 3Configure the router to act as a DHCP server. This step is optional.
    a.At the config-if router prompt, enter the ip dhcp pool server name command.
    b.Enter the import all command to have the Cisco 827 router retrieve the Microsoft Windows 
    nameserver (WINS) and domain name system (DNS) server addresses for name resolution.
    Configuration Example
    The following example shows a configuration of the DHCP client.
    Current configuration:
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname c827
    !
    !
    ip subnet-zero
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool SERVER
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1 
    import all
    ! 
    bridge irb 
    						
    							  
    3-20
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring DHCP
    interface Ethernet0
    ip address 10.10.10.1 255.255.255.0
    no ip directed-broadcast
    ip nat inside
    !
    interface ATM0
    no ip address
    no ip directed-broadcast
    no atm ilmi-keepalive
    bundle-enable
    hold-queue 208 in
    !
    interface ATM0.1 point-to-point
    no ip directed-broadcast
    pvc 1/100 
    encapsulation aal5snap
    !
    bridge-group 1
    !
    interface ATM0.2 point-to-point
    ip address 5.0.0.2 255.0.0.0
    no ip directed-broadcast
    pvc 1/101 
    protocol ip 5.0.0.1 broadcast
    protocol ip 5.0.0.5 broadcast
    encapsulation aal5snap
    !
    !
    interface BVI1
    ip address dhcp client-id Ethernet0
    no ip directed-broadcast
    ip nat outside
    !
    ip nat inside source list 1 interface BVI1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 BVI1
    no ip http server
    !
    access-list 1 permit 10.10.10.0 0.0.0.255
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    voice-port 1
    timing hookflash-in 0
    !
    voice-port 2
    timing hookflash-in 0
    !
    voice-port 3
    timing hookflash-in 0
    !
    voice-port 4
    timing hookflash-in 0
    !
    !
    line con 0
    exec-timeout 0 0
    transport input none
    stopbits 1
    line vty 0 4
    password lab
    login     
    						
    							  
    3-21
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring DHCP
    !
    scheduler max-task-time 5000
    end
    Configuring DHCP Server
    To configure the router as a DHCP server, use the following table, beginning in global configuration 
    mode.
    For more information on the features not used in this configuration, see the Cisco IOS DHCP Server 
    feature module. For more general information on DHCP servers, see Chapter 1, “Concepts.” 
    Configuration Example
    The following configuration shows a DHCP server configuration for the IP address 20.1.1.2.
    !
    ip dhcp pool CLIENT
       network 20.20.20.0 255.255.255.0
       domain-name cisco.com
       default-router 20.20.20.20
       netbios-name-server 1.1.1.1
       dns-server 1.1.1.2
       lease 0 1
    !
    Verifying Your Configuration
    To verify that you have properly configured the DHCP server, enter the show dhcp server command and 
    look for the assigned server IP. You should see a verification output like the example shown below.
    router# show dhcp server 
    show ip dhcp binding
    show ip dhcp conflict
    show ip dhcp server statics
    Command Purpose
    Step 1ip dhcp pool nameEnters DHCP configuration mode, and create a 
    pool of IP addresses that can be assigned to DHCP 
    clients.
    Step 2network ip-address subnet-maskSpecifies a range of IP addresses that can be 
    assigned to the DHCP clients.
    Step 3domain-name domain nameConfigures the domain name.
    Step 4dns-server ip-addressDesignates the router as the default router, and 
    specify an IP address.
    Step 5netbios-name-server ip-addressConfigures the netbios name server.
    Step 6default-router ip-addressConfigures the DNS server.
    Step 7lease days hours minutesSpecifies the duration of the lease.
    Step 8exitExits DHCP configuration mode. 
    						
    							  
    3-22
    Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide
    78-14565-03
    Chapter 3      Basic Router Configuration
    Configuring TACACS+
    Configuring the DHCP Relay
    This section describes how to configure the router to forward User Datagram Protocol (UDP) broadcasts, 
    including IP address requests, from DHCP clients. 
    To configure the DHCP relay, use the following table, beginning in global configuration mode.
    For complete information on the DHCP relay commands, see the Cisco IOS Release 12.2 documentation 
    set. For more general information on DHCP relays, see Chapter 1, “Concepts.” 
    Configuration Example
    The following configuration contains commands relevant to DHCP relay only. 
    You do not need to enter the commands marked “default.” These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    !
    int Ethernet0
    ip address 192.168.100.1 255.255.255.0
    ip helper-address 200.200.200.1
    !
    Verifying Your Configuration
    To verify that you have properly configured the DHCP relay, enter the show dhcp server command. You 
    should see a verification output like the example shown below. 
    router#show dhcp server 
       DHCP server:2.2.2.2
        Leases:  0
        Offers:  0      Requests:0     Acks:0     Naks:0
    Declines:0      Releases:0     Bad: 0
    Configuring TACACS+
    The Cisco 827, 831, 836, 837, 827H, and 827-4V routers and the Cisco SOHO 71, 91, 96, and 97 routers 
    support the Terminal Access Controller Access Control System Plus (TACACS+) protocol through 
    Telnet. TACACS+ is a Cisco proprietary authentication protocol that provides remote access 
    authentication and related network security services, such as event logging. User passwords are Command Purpose
    Step 1interface Ethernet 0Enters configuration mode for the Ethernet 
    interface.
    Step 2ip helper-address addressForwards default UDP broadcasts including IP 
    configuration requests to the DHCP server.
    Step 3no shutdownEnables the Ethernet interface and the 
    configuration changes.
    Step 4exitExits configuration mode for the Ethernet 
    interface. 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 826 Routers Software Configuration Guide