Home > Cisco > Router > Cisco Router 850 Series Software Configuration Guide

Cisco Router 850 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 850 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							 
    4-11
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configuration Example
    NoteIf you want to use NAT with a virtual-template interface, you must configure a loopback interface. See 
    Chapter 1, “Basic Router Configuration,” for information on configuring the loopback interface.
    For complete information on NAT commands, see the Cisco IOS Release 12.3 documentation set. For 
    more general information on NAT concepts, see 
    Appendix B, “Concepts.”
    Configuration Example
    The following configuration example shows a portion of the configuration file for a client in the PPPoA 
    scenario described in this chapter.
    The VLAN interface has an IP address of 192.168.1.1 with a subnet mask of 255.255.255.0. NAT is 
    configured for inside and outside.
    NoteCommands marked by “(default)” are generated automatically when you run the show running-config 
    command.
    !
    interface Vlan1
     ip address 192.168.1.1 255.255.255.0 ip nat inside
     ip virtual-reassembly (default)
    !interface ATM0
     no ip address
     ip nat outside ip virtual-reassembly
     no atm ilmi-keepalive
     pvc 8/35  encapsulation aal5mux ppp dialer
      dialer pool-member 1
     ! dsl operating-mode auto
    !
    Step 10exit
    Example:
    Router(config-if)# exitRouter(config)# 
    Exits configuration mode for the ATM interface.
    Step 11access-list access-list-number {deny | permit} 
    source [source-wildcard]
    Example:
    Router(config)# access-list 1 permit 
    192.168.1.0 0.0.0.255
    Defines a standard access list permitting addresses 
    that need translation.
    NoteAll other addresses are implicitly denied.
    Command Purpose 
    						
    							 
    4-12
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configuration Example
    interface Dialer0 ip address negotiated
     ip mtu 1492
     encapsulation ppp dialer pool 1
     dialer-group 1
     ppp authentication chap!
    ip classless (default)
    !ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255
    ip nat inside source list 1 interface Dialer0 overload
    !access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit
    ip route 10.10.25.2 0.255.255.255 dialer 0
    !
    Verifying Your Configuration
    Use the show ip nat statistics command in privileged EXEC mode to verify the PPPoA client with NAT 
    configuration. You should see verification output similar to the following example:
    Router# show ip nat statistics
    Total active translations: 0 (0 static, 0 dynamic; 0 extended)Outside interfaces:
      ATM0
    Inside interfaces:  Vlan1
    Hits: 0  Misses: 0
    CEF Translated packets: 0, CEF Punted packets: 0Expired translations: 0
    Dynamic mappings:
    -- Inside Source[Id: 1] access-list 1 interface Dialer0 refcount 0
    Queued Packets: 0 
    						
    							
    CH A P T E R
     
    5-1
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    5
    Configuring a LAN with DHCP and VLANs
    The Cisco 870 series routers support clients on both physical LANs and virtual LANs (VLANs). The 
    routers can use the Dynamic Host Configuration Protoc ol (DHCP) to enable automatic assignment of IP 
    configurations for nodes on these networks.
    Figure 5-1  shows a typical deployment scenario with tw o physical LANs connected by the router and 
    two VLANs. 
    Figure 5-1 Physical and Virtual LANs with DHCP Configured on the Cisco Router
    92339
    1
    2
    3
    4
    1Fast Ethernet LAN (with multiple networked devices)
    2Router and DHCP server—Cisco 870 series  access router—connected to the Internet
    3VLAN 1
    4VLAN 2
    DHCP
    DHCP, which is described in RFC 2131, uses a cl ient/server model for address allocation. As an 
    administrator, you can configure your Cisco
     800 series router to act as  a DHCP server, providing IP 
    address assignment and other TCP/IP-oriented configuration information to your workstations. DHCP 
    frees you from having to manually assign an IP address to each client. 
    						
    							 
    5-2
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 5      Configuring a LAN with DHCP and VLANs
      Configure DHCP
    When you configure a DHCP server, you must configure the server properties, policies, and DHCP 
    options. 
    NoteWhenever you change server properties, you must reload the server with the configuration data from the 
    Network Registrar database.
    VLANs
    The Cisco 870 series access routers support four Fast Ethernet ports on which you can configure 
    VLANs.
    VLANs enable networks to be segmented and formed into logical groups of users, regardless of the 
    user’s physical location or LAN connection.
    Configuration Tasks
    Perform the following tasks to configure this network scenario:
     Configure DHCP
     Configure VLANs
    NoteThe procedures in this chapter assume you have already configured basic router features as well as 
    PPPoE or PPPoA with NAT. If you have not performed these configurations tasks, see 
    Chapter 1, “Basic 
    Router Configuration,” Chapter 3, “Configuring PPP over Ethernet with NAT,” and Chapter 4, 
    “Configuring PPP over ATM with NAT” as appropriate for your router.
    Configure DHCP
    Perform these steps to configure your router for DHCP operation, beginning in global configuration 
    mode:
    CommandPurpose
    Step 1ip domain name name
    Example:
    Router(config)# ip domain name smallbiz.com
    Router(config)# 
    Identifies the default domain that the router uses to 
    complete unqualified hostnames (names without a 
    dotted-decimal domain name).
    Step 2ip name-server server-address1 
    [server-address2...server-address6]
    Example:
    Router(config)# ip name-server 192.168.11.12Router(config)# 
    Specifies the address of one or more Domain Name 
    System (DNS) servers to use for name and address 
    resolution. 
    						
    							 
    5-3
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 5      Configuring a LAN with DHCP and VLANs
      Configure DHCP
    Step 3ip dhcp excluded-address low-address 
    [high-address] 
    Example:
    Router(config)# ip dhcp excluded-address 
    192.168.9.0
    Specifies IP addresses that the DHCP server should 
    not assign to DHCP clients. In this example, we are 
    excluding the router address.
    Step 4ip dhcp pool name
    Example:
    Router(config)# ip dhcp pool dpool1
    Router(config-dhcp)# 
    Creates a DHCP address pool on the router and 
    enters DHCP pool configuration mode. The name 
    argument can be a string or an integer.
    Step 5network network-number [mask | prefix-length]
    Example:
    Router(config-dhcp)# network 10.10.0.0 
    255.255.255.0
    Router(config-dhcp)# 
    Defines subnet number (IP) address for the DHCP 
    address pool, optionally including the mask. 
    Step 6import all
    Example:
    Router(config-dhcp)# import allRouter(config-dhcp)# 
    Imports DHCP option parameters into the DHCP 
    portion of the router database.
    Step 7default-router address [address2...address8]
    Example:
    Router(config-dhcp)# default-router 
    10.10.10.10
    Router(config-dhcp)# 
    Specifies up to 8 default routers for a DHCP client.
    Step 8dns-server address [address2...address8]
    Example:
    Router(config-dhcp)# dns-server 192.168.35.2
    Router(config-dhcp)# 
    Specifies up to 8 DNS servers available to a DHCP 
    client.
    Command Purpose 
    						
    							 
    5-4
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 5      Configuring a LAN with DHCP and VLANs
      Configure DHCP
    Configuration Example
    The following configuration example shows a portion of the configuration file for the DCHP 
    configuration described in this chapter.
    ip dhcp excluded-address 192.168.9.0
    !ip dhcp pool dpool1
       import all
       network 10.10.0.0 255.255.255.0   default-router 10.10.10.10
       dns-server 192.168.35.2
       domain-name cisco.com!
    ip domain name smallbiz.com
    ip name-server 192.168.11.12
    Verify Your DHCP Configuration
    Use the following commands to view your DHCP configuration.
     show ip dhcp import—Displays the optional parameters imported into the DHCP server database.
     show ip dhcp pool—Displays information about the DHCP address pools.
     show ip dhcp server statistics—Displays the DHCP server statistics, such as the number of address 
    pools, bindings, and so forth.
    Router# show ip dhcp import
    Address Pool Name: dpool1
    Router# show ip dhcp pool
    Pool dpool1 : Utilization mark (high/low)    : 100 / 0
     Subnet size (first/next)       : 0 / 0
     Total addresses                : 254 Leased addresses               : 0
     Pending event                  : none
     1 subnet is currently in the pool : Current index        IP address range                    Leased addresses
     10.10.0.1            10.10.0.1        - 10.10.0.254       0
    Step 9domain-name domain
    Example:
    Router(config-dhcp)# domain-name cisco.comRouter(config-dhcp)# 
    Specifies the domain name for a DHCP client.
    Step 10exit
    Example:
    Router(config-dhcp)# exit
    Router(config)# 
    Exits DHCP configuration mode, and enters global 
    configuration mode.
    Command Purpose 
    						
    							
     
    5-5
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 5      Configuring a LAN with DHCP and VLANs   Configure VLANs
    Router# show ip dhcp server statistics
    Memory usage         15419
    Address pools        1Database agents      0
    Automatic bindings   0
    Manual bindings      0Expired bindings     0
    Malformed messages   0
    Secure arp entries   0
    Message              Received
    BOOTREQUEST          0DHCPDISCOVER         0
    DHCPREQUEST          0
    DHCPDECLINE          0DHCPRELEASE          0
    DHCPINFORM           0
    Message              Sent
    BOOTREPLY            0
    DHCPOFFER            0DHCPACK              0
    DHCPNAK              0
    Router#
    Configure VLANs
    Perform these steps to configure VLANs on your router, beginning in privileged EXEC mode:
    CommandPurpose
    Step 1vlan database
    Example:
    Router# vlan database
    Router(vlan)# 
    Enters VLAN configuration mode.
    Step 2vlan vlan-id  [media  type] [name  vlan-name ]
    Example:
    Router(vlan)#  vlan 2 media ethernet name 
    VLAN0002
    Router(vlan)#  vlan 3 media ethernet name 
    red-vlan
    Router(vlan)# 
    Adds VLANs, with identifiers ranging from 2 to 1001.
    For details about this command and additional 
    parameters that can be set, see the 
    Cisco IOS 
    Switching Services Command Reference.
    Step 3exit
    Example:
    Router(vlan)#  exitRouter# 
    Updates the VLAN database, propagates it throughout 
    the administrative domain, and returns to privileged 
    EXEC mode. 
    						
    							 
    5-6
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 5      Configuring a LAN with DHCP and VLANs
      Configure VLANs
    Verify Your VLAN Configuration
    Use the following commands to view your VLAN configuration.
     show—Entered from VLAN database mode. Displays summary configuration information for all 
    configured VLANs.
     show vlan-switch—Entered from privileged EXEC mode. Displays detailed configuration 
    information for all configured VLANs. 
    						
    							 
    5-7
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 5      Configuring a LAN with DHCP and VLANs
      Configure VLANs
    Router# vlan databaseRouter(vlan)# show
      VLAN ISL Id: 1
        Name: default    Media Type: Ethernet
        VLAN 802.10 Id: 100001
        State: Operational    MTU: 1500
        Translational Bridged VLAN: 1002
        Translational Bridged VLAN: 1003
      VLAN ISL Id: 1002
        Name: fddi-default    Media Type: FDDI
        VLAN 802.10 Id: 101002
        State: Operational    MTU: 1500
        Bridge Type: SRB
        Translational Bridged VLAN: 1    Translational Bridged VLAN: 1003
      VLAN ISL Id: 1003    Name: token-ring-default
        Media Type: Token Ring
        VLAN 802.10 Id: 101003
        State: Operational    MTU: 1500
        Bridge Type: SRB
        Ring Number: 0    Bridge Number: 1
        Parent VLAN: 1005
        Maximum ARE Hop Count: 7    Maximum STE Hop Count: 7
        Backup CRF Mode: Disabled
        Translational Bridged VLAN: 1    Translational Bridged VLAN: 1002
      VLAN ISL Id: 1004    Name: fddinet-default
        Media Type: FDDI Net
        VLAN 802.10 Id: 101004    State: Operational
        MTU: 1500
        Bridge Type: SRB    Bridge Number: 1
        STP Type: IBM
      VLAN ISL Id: 1005
        Name: trnet-default
        Media Type: Token Ring Net    VLAN 802.10 Id: 101005
        State: Operational
        MTU: 1500    Bridge Type: SRB
        Bridge Number: 1
        STP Type: IBM 
    						
    							 
    5-8
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 5      Configuring a LAN with DHCP and VLANs
      Configure VLANs
    Router# show vlan-switch
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------1    default                          active    Fa0, Fa1, Fa2, Fa3
    1002 fddi-default                     active
    1003 token-ring-default               active1004 fddinet-default                  active
    1005 trnet-default                    active
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   10031002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        ibm  -        0      01005 trnet 101005     1500  -      -      1        ibm  -        0      0
    Router# 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 850 Series Software Configuration Guide