Home > Cisco > Router > Cisco Router 850 Series Software Configuration Guide

Cisco Router 850 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 850 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							
    CH A P T E R
     
    4-1
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    121753
    2
    3
    5
    6
    1
    7
    4
    4
    Configuring PPP over ATM with NAT
    The Cisco 857, Cisco 876, Cisco 877, and Cisco 878 access routers support Point-to-Point Protocol over 
    Asynchronous Transfer Mode (PPPoA) client s and network address translation (NAT). 
    Multiple PCs can be connected to the LAN behind the router. Before traffic from the PCs is sent to the 
    PPPoA session, it can be encrypted, filtered, and so  forth. PPP over ATM provides a network solution 
    with simplified address handling and straight user verification like a dial network. 
    Figure 4-1 shows a 
    typical deployment scenario with  a PPPoA client and NAT configured on  the Cisco router. This scenario 
    uses a single static IP ad dress for the ATM connection.
    Figure 4-1 PPP over ATM with NAT
    92340
    2
    3
    5
    1
    6
    4
    ISP
    1Small business with multiple networked devices—desktops, laptop PCs, switches
    2Fast Ethernet LAN interface (insid e interface for NAT, 192.168.1.1/24)
    3PPPoA Client—Cisco 857, Cisco 876, Cisco 877, or Cisco 878 router
    4Point at which NAT occurs
    5ATM WAN interface (outside interface for NAT)
    6PPPoA session between the client and a PPPoA server at the ISP 
    						
    							 
    4-2
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      
    In this scenario, the small business or remote user on the Fast Ethernet LAN can connect to an Internet 
    service provider (ISP) using the following protocols on the WAN connection:
     Asymmetric digital subscriber line (ADSL) over plain old telephone service (POTS) using the 
    Cisco
     857 or Cisco 877 router
     ADSL over integrated services digital network (ISDN) using the Cisco 876 router
     Single-pair high-speed digital subscriber line (G.SHDSL) using the Cisco 878 router
    The Fast Ethernet interface carries the data packet through the LAN and off-loads it to the PPP 
    connection on the ATM interface. The ATM traffic is encapsulated and sent over the ADSL, ISDN, or 
    G.SHDSL lines. The dialer interface is used to connect to the ISP.
    PPPoA
    The PPPoA Client feature on the router provides PPPoA client support on ATM interfaces. A dialer 
    interface must be used for cloning virtual access. Multiple PPPoA client sessions can be configured on 
    an ATM interface, but each session must use a separate dialer interface and a separate dialer pool. 
    A PPPoA session is initiated on the client side by the Cisco 850 or Cisco 870 series router.
    NAT
    NAT (represented as the dashed line at the edge of the Cisco router) signifies two addressing domains 
    and the inside source address. The source list defines how the packet travels through the network.
    Configuration Tasks
    Perform the following tasks to configure this network scenario:
     Configure the Dialer Interface
     Configure the ATM WAN Interface
     Configure DSL Signaling Protocol
     Configure Network Address Translation
    An example showing the results of these configuration tasks is shown in the “Configuration Example” 
    section on page 4-11. 
    						
    							 
    4-3
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configure the Dialer Interface
    Configure the Dialer Interface
    The dialer interface indicates how to handle traffic from the clients, including, for example, default 
    routing information, the encapsulation protocol, and the dialer pool to use. It is also used for cloning 
    virtual access. Multiple PPPoA client sessions can be configured on an ATM interface, but each session 
    must use a separate dialer interface and a separate dialer pool.
    Perform these steps to configure a dialer interface for the ATM interface on the router, starting in global 
    configuration mode. 
    CommandPurpose
    Step 1interface dialer dialer-rotary-group-number
    Example:
    Router(config)# interface dialer 0
    Router(config-if)# 
    Creates a dialer interface (numbered 0–255), and 
    enters into interface configuration mode.
    Step 2ip address negotiated
    Example:
    Router(config-if)# ip address negotiatedRouter(config-if)# 
    Specifies that the IP address for the dialer 
    interface is obtained through PPP/IPCP (IP 
    Control Protocol) address negotiation.
    Step 3ip mtu bytes
    Example:
    Router(config-if)# ip mtu 4470
    Router(config-if)# 
    Sets the size of the IP maximum transmission unit 
    (MTU). The default minimum is 128
     bytes. The 
    maximum for ATM is 4470
     bytes.
    Step 4encapsulation encapsulation-type
    Example:
    Router(config-if)# encapsulation ppp
    Router(config-if)# 
    Sets the encapsulation type to PPP for the data 
    packets being transmitted and received.
    Step 5ppp authentication {protocol1 [protocol2...]}
    Example:
    Router(config-if)# ppp authentication chapRouter(config-if)# 
    Sets the PPP authentication method.
    The example applies the Challenge Handshake 
    Authentication Protocol (CHAP).
    For details about this command and additional 
    parameters that can be set, see the Cisco IOS 
    Security Command Reference.
    Step 6dialer pool number
    Example:
    Router(config-if)# dialer pool 1
    Router(config-if)# 
    Specifies the dialer pool to use to connect to a 
    specific destination subnetwork. 
    						
    							 
    4-4
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configure the Dialer Interface
    Repeat these steps for any additional dialer interfaces or dialer pools needed.
    Step 7dialer-group group-number
    Example:
    Router(config-if)# dialer-group 1Router(config-if)# 
    Assigns the dialer interface to a dialer group 
    (1–10).
    TipUsing a dialer group controls access to 
    your router.
    Step 8exit
    Example:
    Router(config-if)# exit
    Router(config)# 
    Exits the dialer 0 interface configuration.
    Step 9dialer-list dialer-group protocol protocol-name 
    {permit | deny | list access-list-number | 
    access-group} 
    Example:
    Router(config)# dialer-list 1 protocol ip 
    permit
    Router(config)# 
    Creates a dialer list and associates a dial group 
    with it. Packets are then forwarded through the 
    specified interface dialer group. 
    For details about this command and additional 
    parameters that can be set, see the Cisco IOS Dial 
    Technologies Command Reference.
    Step 10ip route prefix mask {interface-type 
    interface-number}
    Example:
    Router(config)# ip route 10.10.25.2 
    0.255.255.255 dialer 0
    Router(config)# 
    Sets the IP route for the default gateway for the 
    dialer 0 interface.
    For details about this command and additional 
    parameters that can be set, see the Cisco IOS IP 
    Command Reference, Volume 1 of 4: Routing 
    Protocols. 
    Command Purpose 
    						
    							 
    4-5
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configure the ATM WAN Interface
    Configure the ATM WAN Interface
    Perform these steps to configure the ATM interface, beginning in global configuration mode.
    CommandPurpose
    Step 1interface type number
    Example:
    Router(config)# interface atm 0Router(config-if)# 
    Enters interface configuration mode for the ATM 
    interface (labeled ADSLoPOTS or G.SHDSL on 
    the back of your router).
    NoteThis interface was initially configured 
    during basic router configuration. See the 
    “Configure WAN Interfaces” section on 
    page 1-6.
    Step 2pvc vpi/vci
    Example:
    Router(config-if)# pvc 8/35
    Router(config-if-atm-vc)# 
    Creates an ATM PVC for each end node (up to ten) 
    with which the router communicates. Enters ATM 
    virtual circuit configuration mode.
    When a PVC is defined, AAL5SNAP 
    encapsulation is defined by default. Use the 
    encapsulation command to change this, as shown 
    in 
    Step 3. The VPI and VCI arguments cannot be 
    simultaneously specified as zero; if one is 0, the 
    other cannot be 0. 
    For details about this command and additional 
    parameters that can be set, see the Cisco IOS 
    Wide-Area Networking Command Reference.
    Step 3encapsulation {aal5auto | aal5autoppp 
    virtual-template number [group group-name] | 
    aal5ciscoppp virtual-template number | 
    aal5mux protocol | aal5nlpid | aal5snap} 
    Example:
    Router(config-if-atm-vc)# encapsulation 
    aal5mux ppp dialer
    Router(config-if-atm-vc)# 
    Specifies the encapsulation type for the PVC and 
    points back to the dialer interface. 
    For details about this command and additional 
    parameters that can be set, see the Cisco IOS 
    Wide-Area Networking Command Reference.
    Step 4dialer pool-member number
    Example:
    Router(config-if-atm-vc)# dialer 
    pool-member 1
    Router(config-if-atm-vc)# 
    Specifies the ATM interface as a member of a 
    dialer profile dialing pool. The pool number must 
    be in the range of 1–255. 
    						
    							
     
    4-6
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configure DSL Signaling Protocol
    Configure DSL Signaling Protocol
    DSL signaling must be configured on the ATM interface for connection to your ISP. The Cisco 857 and 
    Cisco
     877 routers support ADSL signaling over POTS, the Cisco 876 supports ADSL signaling over 
    ISDN, and the Cisco
     878 supports SHDSL signaling. Based on the router you are configuring, see one 
    of the following sections to configure the appropriate DSL signaling protocol.
     Configuring ADSL
     Configuring SHDSL
    Configuring ADSL
    The default configuration for ADSL signaling is shown in  Ta b l e 4-1. 
    Ta b l e 4-1 Default ADSL Configuration
    AttributeDescriptionDefault Value
    Operating modeSpecifies the operating mode of the digital subscriber line 
    (DSL) for an ATM interface.
     ADSL over POTS—ANSI or ITU full rate, or 
    automatic selection.
     ADSL over ISDN—ITU full rate, ETSI, or 
    automatic
     selection.
    Auto
    Loss of marginSpecifies the number of times a loss of margin may occur.—
    Training logToggles between enabling the training log and disabling the 
    training log.Disabled
    Step 5no shutdown
    Example:
    Router(config-if-atm-vc)#  no shutdownRouter(config-if)# 
    Enables interface and configuration changes just 
    made to the ATM interface.
    Step 6exit
    Example:
    Router(config-if)# exit
    Router(config)# 
    Exits configuration mode for the ATM interface.
    Command Purpose 
    						
    							 
    4-7
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configure DSL Signaling Protocol
    If you wish to change any of these settings, use one of the following commands in global configuration 
    mode.
     dsl operating-mode (from the ATM interface configuration mode)
     dsl lom integer
     dsl enable-training-log
    See the Cisco IOS Wide-Area Networking Command Reference for details of these commands.
    Verify the Configuration
    You can verify that the configuration is set the way you want by using the show dsl interface atm 
    command from privileged EXEC mode.
    Configuring SHDSL
    Complete the following steps to configure the DSL controller in your router to use SHDSL signaling, 
    beginning in global configuration mode.
    CommandPurpose
    Step 1controller dsl port
    Example:
    Router(config)# controller dsl 0
    Router(config-controller)# 
    Enters the configuration mode for the DSL 
    controller.
    Step 2line-term {co | cpe}
    Example:
    Router(config-controller)# line-term co
    Router(config-controller)# 
    Specifies if the DSL line is terminated at a central 
    office (CO) or at customer premises equipment 
    (CPE).
    Step 3exit
    Example:
    Router(config-controller)# exitRouter(config)# 
    Exits controller configuration mode, returning to 
    global configuration mode.
    Step 4mode protocol
    Example:
    Router(config)# mode atm
    Router(config-controller)# 
    Specifies the mode of the DSL controller and 
    enters controller configuration mode.
    Step 5line-mode {4-wire | 2-wire}
    Example:
    Router(config-controller)# line-mode 4-wire
    Router(config-controller)# 
    Specifies whether this DSL connection is 
    operating in 2-wire or 4-wire mode. 
    						
    							 
    4-8
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configure DSL Signaling Protocol
    NoteIf you are integrating your Cisco router into a European network, use the dsl dsl-mode shdsl symmetric 
    annex {A | B} command to choose annex B. The router uses annex A by default (United States).
    Verify the Configuration
    You can verify that the configuration is set the way you want by using the show controllers dsl command 
    from the privileged EXEC mode.
    Router# show controllers dsl 0
    DSL 0 controller UP
    SLOT 0: Globespan xDSL controller chipsetDSL mode: SHDSL Annex A
    Frame mode: Utopia
    Configured Line rate: AutoLine Re-activated 6 times after system bootup
    LOSW Defect alarm: ACTIVE
    CRC per second alarm: ACTIVELine termination: CPE
    Current 15 min CRC: 0Current 15 min LOSW Defect: 0
    Current 15 min ES Defect: 0
    Current 15 min SES Defect: 0Current 15 min UAS Defect: 33287
    Previous 15 min CRC Defect: 0Previous 15 min LOSW Defect: 0
    Previous 15 min ES Defect: 0
    Previous 15 min SES Defect: 0Previous 15 min UAS Defect: 0
    Line-0 statusChipset Version: 0
    Firmware Version: A388
    Modem Status: Data, Status 1Last Fail Mode: No Failure status:0x0
    Line rate: 2312 Kbps
    Framer Sync Status: In SyncRcv Clock Status: In the Range
    Loop Attenuation: 341.1450 dB
    Transmit Power: 7.5 dB
    Step 6ignore-error-duration number
    Example:
    Router(config-controller)# 
    ignore-error-duration 15
    Router(config-controller)# 
    Specifies how long, 15 to 30 seconds, to ignore 
    errors.
    Step 7exit
    Example:
    Router(config-controller)# exitRouter(config)# 
    Exits controller configuration mode, returning to 
    global configuration mode.
    Command Purpose 
    						
    							 
    4-9
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configure Network Address Translation
    Receiver Gain: 22.5420 dBSNR Sampling: 36.8590 dB
    Dying Gasp: Present
    Configure Network Address Translation
    Network Address Translation (NAT) translates packets from addresses that match a standard access list, 
    using global addresses allocated by the dialer interface. Packets that enter the router through the inside 
    interface, packets sourced from the router, or both are checked against the access list for possible address 
    translation. You can configure NAT for either static or dynamic address translations.
    Perform these steps to configure the outside ATM WAN interface with dynamic NAT, beginning in global 
    configuration mode:
    CommandPurpose
    Step 1ip nat pool name start-ip end-ip {netmask 
    netmask | prefix-length prefix-length}
    Example:
    Router(config)# ip nat pool pool1 
    192.168.1.0 192.168.2.0 netmask 0.0.0.255
    Router(config)# 
    Creates pool of global IP addresses for NAT. 
    Step 2ip nat inside source {list access-list-number} 
    {interface type number | pool name} [overload]
    Example 1:
    Router(config)# ip nat inside source list 1 
    interface dialer 0 overload
    or
    Example 2:
    Router(config)# ip nat inside source list 
    acl1 pool pool1
    Enables dynamic translation of addresses on the 
    inside interface.
    The first example shows the addresses permitted 
    by the access list 1 to be translated to one of the 
    addresses specified in the dialer interface 0.
    The second example shows the addresses 
    permitted by access list acl1 to be translated to one 
    of the addresses specified in the NAT pool pool1.
    For details about this command and additional 
    parameters that can be set, as well as information 
    about enabling static translation, see the 
    Cisco IOS IP Command Reference, Volume 1 of 4: 
    Addressing and Services.
    Step 3interface type number
    Example:
    Router(config)# interface vlan 1Router(config-if)# 
    Enters configuration mode for the VLAN (on 
    which the Fast Ethernet LAN interfaces 
    [FE0–FE3] reside) to be the inside interface for 
    NAT. 
    						
    							 
    4-10
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 4      Configuring PPP over ATM with NAT
      Configure Network Address Translation
    Step 4ip nat {inside | outside}
    Example:
    Router(config-if)# ip nat insideRouter(config-if)# 
    Applies NAT to the Fast Ethernet LAN interface 
    as the inside interface.
    For details about this command and additional 
    parameters that can be set, as well as information 
    about enabling static translation, see the 
    Cisco IOS IP Command Reference, Volume 1 of 4: 
    Addressing and Services.
    Step 5no shutdown
    Example:
    Router(config-if)# no shutdown
    Router(config-if)# 
    Enables the configuration changes just made to the 
    Ethernet interface.
    Step 6exit
    Example:
    Router(config-if)# exit
    Router(config)# 
    Exits configuration mode for the Fast Ethernet 
    interface.
    Step 7interface type number
    Example:
    Router(config)# interface atm 0
    Router(config-if)# 
    Enters configuration mode for the ATM WAN 
    interface (ATM0) to be the outside interface for 
    NAT.
    Step 8ip nat {inside | outside}
    Example:
    Router(config-if)# ip nat outside
    Router(config-if)# 
    Identifies the specified WAN interface as the NAT 
    outside interface.
    For details about this command and additional 
    parameters that can be set, as well as enabling 
    static translation, see the 
    Cisco IOS IP Command 
    Reference, Volume 1 of 4: Addressing and 
    Services.
    Step 9no shutdown
    Example:
    Router(config-if)# no shutdownRouter(config-if)# 
    Enables the configuration changes just made to the 
    Ethernet interface.
    Command Purpose 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 850 Series Software Configuration Guide