Home > Cisco > Router > Cisco Router 850 Series Software Configuration Guide

Cisco Router 850 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 850 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							 
    13-19
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the ISDN S/T Port
    Step 8ip address negotiated
    Example:
    Router(config-if)# ip address negotiatedRouter(config-if)#
    Specifies that the IP address for the interface is 
    obtained through PPP/IPCP (IP Control Protocol) 
    address negotiation. The IP address is obtained 
    from the peer.
    Step 9encapsulation encapsulation-type
    Example:
    Router(config-if)# encapsulation ppp
    Router(config-if)#
    Sets the encapsulation type to PPP for the 
    interface.
    Step 10dialer pool number
    Example:
    Router(config-if)# dialer pool 1
    Router(config-if)#
    Specifies the dialer pool to be used. 
    In the example, the dialer pool 1 setting associates 
    the dialer 0 interface with the BRI0 interface 
    because the BRI0 dialer pool-member value is 1.
    Step 11dialer string dial-string[:isdn-subaddress]
    Example:
    Router(config-if)# dialer string 384040
    Router(config-if)#
    Specifies the telephone number to be dialed.
    Step 12dialer-group group-number
    Example:
    Router(config-if)# dialer group 1
    Router(config-if)#
    Assigns the dialer interface to a dialer group 
    (1–10).
    Step 13exit
    Example:
    Router(config-if)# exitRouter(config)#
    Exits dialer 0 interface configuration mode, and 
    enters global configuration mode.
    Step 14dialer-list dialer-group protocol protocol-name 
    {permit | deny | list access-list-number | 
    access-group} 
    Example:
    Router(config)# dialer-list 1 protocol ip 
    permit
    Router(config)#
    Creates a dialer list for packets of interest to be 
    forwarded through the specified interface dialer 
    group. 
    In the example, dialer-list 1 corresponds to 
    dialer-group 1.
    For details about this command and additional 
    parameters that can be set, see the 
    Cisco IOS Dial 
    Technologies Command Reference.
    Command Purpose 
    						
    							 
    13-20
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the ISDN S/T Port
    Configure the Aggregator and ISDN Peer Router
    The aggregator is typically a concentrator router where your Cisco router ATM PVC terminates. In the 
    configuration example shown below, the aggregator is configured as a PPPoE server to correspond with 
    the Cisco
     876 router configuration example that is given in this chapter.
    The ISDN peer router is any router that has an ISDN interface and can communicate through a public 
    ISDN network to reach your Cisco router ISDN interface. The ISDN peer router provides Internet access 
    for your Cisco router during the ATM network downtime.
    ! This portion of the example configures the aggregator.
    vpdn enable
    no vpdn logging!
    vpdn-group 1
     accept-dialin protocol pppoe
     virtual-template 1
    !interface Ethernet3
     description “4700ref-1”
     ip address 40.1.1.1 255.255.255.0 media-type 10BaseT
    !
    interface Ethernet4
     ip address 30.1.1.1 255.255.255.0 media-type 10BaseT
    !
    interface Virtual-Template1 ip address 22.0.0.2 255.255.255.0
     ip mtu 1492
     peer default ip address pool adsl!
    interface ATM0
     no ip address pvc 1/40
     encapsulation aal5snap
     protocol pppoe!
    no atm limi-keepalive
    !ip local pool adsl 22.0.0.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 22.0.0.1 50ip route 0.0.0.0 0.0.0.0 30.1.1.2.80
    ! This portion of the example configures the ISDN peer.isdn switch-type basic-net3
    !
    interface Ethernet0 ip address 30.1.1.2 255.0.0.0 
    !
    interface BRI0 description “to 836-dialbackup”
     no ip address
     encapsulation ppp dialer pool-member 1
     isdn switch-type basic-net3
    ! 
    						
    							 
    13-21
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the ISDN S/T Port
    interface Dialer0 ip address 192.168.2.2 255.255.255.0
     encapsulation ppp
     dialer pool 1 dialer string 384020
     dialer-group 1
     peer default ip address pool isdn!
    ip local pool isdn 192.168.2.1
    ip http serverip classless
    ip route 0.0.0.0 0.0.0.0 192.168.2.1
    ip route 40.0.0.0 255.0.0.0 30.1.1.1!
    dialer-list 1 protocol ip permit
    ! 
    						
    							 
    13-22
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the ISDN S/T Port 
    						
    							CH A P T E R
     
    14-1
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    14
    Troubleshooting
    Use the information in this chapter to help isolate problems you might encounter or to rule out the router 
    as the source of a problem. This chapter contains the following sections:
     Getting Started
     Before Contacting Cisco or Your Reseller
     ADSL Troubleshooting
     SHDSL Troubleshooting
     ATM Troubleshooting Commands
     Software Upgrade Methods
     Recovering a Lost Password
     Managing Your Router with SDM
    Getting Started
    Before troubleshooting a software problem, you must connect a terminal or PC to the router using the 
    light-blue console port. (For information on making this connection, see the documentation listed in the 
    “Related Documents” section on page 14.) With a connected terminal or PC, you can view status 
    messages from the router and enter commands to troubleshoot a problem.
    You can also remotely access the interface (Ethernet, ADSL, or telephone) by using Telnet. The Telnet 
    option assumes that the interface is up and running.
    Before Contacting Cisco or Your Reseller
    If you cannot locate the source of a problem, contact your local reseller for advice. Before you call, you 
    should have the following information ready:
     Chassis type and serial number
     Maintenance agreement or warranty information
     Type of software and version number 
     Date you received the hardware
     Brief description of the problem
     Brief description of the steps you have taken to isolate the problem 
    						
    							 
    14-2
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 14      Troubleshooting
      ADSL Troubleshooting
    ADSL Troubleshooting
    If you experience trouble with the ADSL connection, verify the following:
     The ADSL line is connected and is using pins 3 and 4. For more information on the ADSL 
    connection, see the hardware guide for your router.
     The ADSL CD LED is on. If it is not on, the router may not be connected to the DSL access 
    multiplexer (DSLAM). For more information on the ADSL LEDs, see the hardware installation 
    guide specific for your router.
     The correct Asynchronous Transfer Mode (ATM) virtual path identifier/virtual circuit identifier 
    (VPI/VCI) is being used.
     The DSLAM supports discrete multi-tone (DMT) Issue 2.
     The ADSL cable that you connect to the Cisco router must be 10BASE-T Category 5, unshielded 
    twisted-pair (UTP) cable. Using regular telephone cable can introduce line errors.
    SHDSL Troubleshooting
    Symmetrical high-data-rate digital subscriber line (SHDSL) is available on Cisco 878 and Cisco 1803 
    router models. If you experience trouble with the SHDSL connection, verify the following:
     The SHDSL line is connected and using pins 3 and 4. For more information on the G.SHDSL 
    connection, see the hardware guide for your router.
     The G.SHDSL LED is on. If it is not on, the router may not be connected to the DSL access 
    multiplexer (DSLAM). For more information on the G.SHDSL LED, see the hardware installation 
    guide specific for your router.
     The correct asynchronous transfer mode (ATM) virtual path identifier/virtual circuit identifier 
    (VPI/VCI) is being used.
     The DSLAM supports the G.SHDSL signaling protocol.
    Use the show controllers dsl 0 command in EXEC mode to view an SHDSL configuration.
    ATM Troubleshooting Commands
    Use the following commands to troubleshoot your ATM interface.
     ping atm interface Command
     show interface Command
     show atm interface Command
     debug atm Commands 
    						
    							 
    14-3
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 14      Troubleshooting
      ATM Troubleshooting Commands
    ping atm interface Command
    Use the ping atm interface command to determine whether a particular PVC is in use. The PVC does 
    not need to be configured on the router to use this command. 
    Example 14-1 shows the use of this 
    command to determine whether PVC 8/35 is in use.
    Example 14-1 Determining If a PVC Is in Use
    Router# ping atm interface atm 0 8 35 seg-loopback 
    Type escape sequence to abort.
    Sending 5, 53-byte segment OAM echoes, timeout is 2 seconds:
    !!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 148/148/148 ms
    This command sends five OAM F5 loopback packets to the DSLAM (segment OAM packets). If the PVC 
    is configured at the DSLAM, the ping is successful.
    To test whether the PVC is being used at the aggregator, enter the following command:
    Router# ping atm interface atm 0 8 35 end-loopback 
    Type escape sequence to abort.Sending 5, 53-byte end-to-end OAM echoes, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 400/401/404 ms
    This command sends end-to-end OAM F5 packets, which are echoed back by the aggregator.
    show interface Command
    Use the show interface command to display the status of all physical ports (Ethernet and ATM) and 
    logical interfaces on the router. 
    Ta b l e 14-1 describes messages in the command output.
    Example 14-2 Viewing Status of Selected Interfaces
    Router# show interface atm 0
    ATM0 is up, line protocol is up   Hardware is PQUICC_SAR (with Alcatel ADSL Module)
      Internet address is 14.0.0.16/8
      MTU 1500 bytes, sub MTU 1500, BW 640 Kbit, DLY 80 usec,      reliability 40/255, txload 1/255, rxload 1/255
      Encapsulation ATM, loopback not set
      Keepalive not supported   Encapsulation(s):AAL5, PVC mode
      10 maximum active VCs, 1 current VCCs
      VC idle disconnect time:300 seconds  Last input 01:16:31, output 01:16:31, output hang never
      Last clearing of show interface counters never
      Input queue:0/75/0 (size/max/drops); Total output drops:0  Queueing strategy:Per VC Queueing
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec     512 packets input, 59780 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 1024 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
    						
    							 
    14-4
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 14      Troubleshooting
      ATM Troubleshooting Commands
         426 packets output, 46282 bytes, 0 underruns     0 output errors, 0 collisions, 2 interface resets
         0 output buffer failures, 0 output buffers swapped out
    Router# show interface fastethernet 0
    Ethernet0 is up, line protocol is up 
    Hardware is PQUICC Ethernet, address is 0000.Oc13.a4db (bia0010.9181.1281)
    Internet address is 170.1.4.101/24
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, reliability 255/255., txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Router# show interface dialer 1
    Dialer 1 is up, line protocol is up Hardware is Dialer interface
    Internet address is 1.1.1.1/24
    MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec, reliability255/255. txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Keepalive set (10 sec)DTR is pulsed for 5 seconds on reset
    LCP Closed
    Ta b l e 14-1 describes possible command output for the show interface command. 
    Ta b l e 14-1 show interface Command Output Description 
    Output Cause
    For ATM Interfaces
    ATM 0 is up, line protocol is upThe ATM line is up and operating correctly.
    ATM 0 is down, line protocol is down The ATM interface has been disabled with the 
    shutdown command. 
    or
     The ATM line is down, possibly because the 
    ADSL cable is disconnected or because the 
    wrong type of cable is connected to the ATM 
    port.
    AT M  0 .n is up, line protocol is up The specified ATM subinterface is up and operating 
    correctly.
    AT M  0 .n is administratively down, line protocol 
    is downThe specified ATM subinterface has been disabled 
    with the shutdown command.
    AT M  0 .n is down, line protocol is downThe specified ATM subinterface is down, possibly 
    because the ATM line has been disconnected (by the 
    service provider).
    For Fast Ethernet Interfaces
    Fast Ethernet n is up, line protocol is upThe specified Fast Ethernet interface is connected to 
    the network and operating correctly.
    Fast Ethernet n is up, line protocol is downThe specified Fast Ethernet interface has been 
    correctly configured and enabled, but the Ethernet 
    cable might be disconnected from the LAN. 
    						
    							 
    14-5
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 14      Troubleshooting
      ATM Troubleshooting Commands
    show atm interface Command
    To display ATM-specific information about an ATM interface, use the show atm interface atm 0 
    command from privileged EXEC mode, as shown in 
    Example 14-3.
    Example 14-3 Viewing Information About an ATM Interface
    Router# show atm interface atm 0Interface ATM0:
    AAL enabled: AAL5 , Maximum VCs:11, Current VCCs:0
    Maximum Transmit Channels:0
    Max. Datagram Size:1528
    PLIM Type:INVALID - 640Kbps, Framing is INVALID,DS3 lbo:short, TX clocking:LINE
    0 input, 0 output, 0 IN fast, 0 OUT fast
    Avail bw = 640 Config. is ACTIVE
    Ta b l e 14-2 describes some of the fields shown in the command output.
    Fast Ethernet n is administratively down, line 
    protocol is downThe specified Fast Ethernet interface has been 
    disabled with the shutdown command, and the 
    interface is disconnected.
    For Dialer Interfaces
    Dialer n is up, line protocol is upThe specified dialer interface is up and operating 
    correctly.
    Dialer n is down, line protocol is down This is a standard message and may not indicate 
    anything is actually wrong with the 
    configuration.
    or
     If you are having problems with the specified 
    dialer interface, this can mean it is not 
    operating, possibly because the interface has 
    been brought down with the shutdown 
    command, or the ADSL cable is disconnected.
    Table 14-1 show interface Command Output Description (continued)
    Output Cause
    Ta b l e 14-2 show atm interface Command Output Description 
    FieldDescription
    AT M  i n t e r f a c eInterface number. Always 0 for the Cisco 850 and Cisco 870 series access routers.
    AAL enabledType of AAL enabled. The Cisco 850 and Cisco 870 series access routers support 
    AAL5.
    Maximum VCsMaximum number of virtual connections this interface supports.
    Current VCCsNumber of active virtual channel connections (VCCs). 
    						
    							 
    14-6
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 14      Troubleshooting
      ATM Troubleshooting Commands
    debug atm Commands
    Use the debug commands to troubleshoot configuration problems that you might be having on your 
    network. The debug commands provide extensive, informative displays to help you interpret any 
    possible problems. 
    Guidelines for Using Debug Commands
    Read the following guidelines before using debug commands to ensure appropriate results.
     All debug commands are entered in privileged EXEC mode.
     To view debugging messages on a console, enter the logging console debug command.
     Most debug commands take no arguments.
     To disable debugging, enter the undebug all command.
     To  u s e  debug commands during a Telnet session on your router, enter the terminal monitor 
    command.
    CautionDebugging is assigned a high priority in your router CPU process, and it can render your router unusable. 
    For this reason, use debug commands only to troubleshoot specific problems. The best time to use debug 
    commands is during periods of low network traffic so that other activity on the network is not adversely 
    affected.
    You can find additional information and documentation about the debug commands in the Cisco IOS 
    Debug Command Reference.
    debug atm errors Command
    Use the debug atm errors command to display ATM errors. The no form of this command disables 
    debugging output. 
    Example 14-4 shows a sample output.
    Example 14-4 Viewing ATM Errors
    Router# debug atm errorsATM errors debugging is on
    Router#
    01:32:02:ATM(ATM0.2):VC(3) Bad SAP received 450001:32:04:ATM(ATM0.2):VC(3) Bad SAP received 4500
    01:32:06:ATM(ATM0.2):VC(3) Bad SAP received 4500
    Maximum 
    Transmit
     
    Channels
    Maximum number of transmit channels.
    Max Datagram 
    SizeConfigured maximum number of bytes in the largest datagram.
    PLIM TypePhysical layer interface module (PLIM) type.
    Table 14-2 show atm interface Command Output Description (continued)
    Field Description 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 850 Series Software Configuration Guide